Http://homeassistant.local:8123 link does not work and my Rpi is not seen by router


I followed instruction to flash a new SD card and installed it into my new RPi4, but I am anable to complete the configuration of Home Assistant becouse my router do not list my device, connected by ethernet cable.
What should I do?

Thanks, Claudio

Put a monitor on the RPi and see what it prints out on the screen there.

Unfortunately I don’t have a suitable connection cable with a micro HDMI plug to use with the new RPi4 !!!

Well, it will make the bug hunt harder then. :slight_smile:

First make sure your cable is at least cat 5e or better and that it is working.
Next check if the leds start to turn on or blink at the ethernet port on the RPi when it is turned on and physically connected to the router.
If there is no lights, then check that the router port is working by connecting another device with the same cable.
If that works, then it sounds like your RPi might have issues with its ethernet port and you really should get a monitor cable then.

You are write!
I am trying to find a cable switable to my need .
My Ethernet cable is fine, since it works good with my PC.
The Ethernet Port of my RPi4 lights yellow when connected with such a cable, but my routers doesn’t list the device!


I have bought the right HDMI cable and I se on the screen that there are No bootable partitions.
What should I do?


Sounds like the flashing went wrong.
It should mark one of the partitions as active and bootable.
Try it again and make sure you download the right image.

Thanks, do you know how to make a partition bootable?

read the second note here:

I’m not sure which note you are indicating but I found a way to flag (by Gparted) the hasso-boot partion as “boot” intsead of the acutual “msftrees”.
Could be a good trial?

The page has a blue bar with Note written in it in the first few lines.
The second blue bar with Note written in it is about making a partition bootable.

clicking “Start up your Generic x86-64” in the right side brings you pretty close to it.

I don’t think the note solves my problem. As I understand, the note can be applied to a PC where you can access the BIOS, but I don’t think the Raspberry has a BIOS and, in any case, I don’t know how to access it.

The setting is on the partition, so if you move the SDcard, then the setting follows.
And the way it is down is by making a Live Ubuntu USB stick and boot from that on whatever device the SDCard is in at the time.
It can be a RPi or a PC.

If the setting will be on the boot partition of my SD card, i think it is possible to change the flag as I proposed above by Ubuntu > GParted,
Am I right?

In case it is recommended to follow the instruction of the note, I should give the following command to an Ubuntu terminal, where mmcblk0 is the name of MY SD card as seen by GParted?

efibootmgr --create --disk /dev/mmcblk0 --part 1 --label “HAOS”
–loader ‘\EFI\BOOT\bootx64.efi’

Is the first time that I’m going to use such a command and I found strange that is written in 2 rows!

waiting for your reply, I tried to verify what would have happened by changing the “msftrees” flag to “boot” and I noticed that GParted also added the “esp” flag.
I approved the change, then I inserted the SD card on the Raspberry, started it and, finally, after 2/3 minutes of running the script, the monitor screen showed the HomeAsistant prompt “ha>”
Now I hope I can complete the installation by following the guide

I had to step away a bit, but it sounds like you found a way.
Now comes the part with a little bit of frustration and a lot of reinstalls.
This is the part where you after a good bit of setups and configurations realize you could have done it smarter and therefore need to start over. :stuck_out_tongue:
It is kind a rite of passage.

Thanks for your help :smiley: