Home Assistant Community

Http in node

#1

Hi all.

I have been using a http node to get a web request into a flow and was working wonderfully. I was using Hassio vers .89 something. I upgraded Hassio and Node red etc to the latest and had to ask how to get to the old web interface.

However I now cant get the http in node to work. Trying it from a browser it asks the login name and password and I used the same one I have been using for weeks and checked it was in the config file but it keeps getting rejected.
I am out of ideas?

[20/Apr/2019:20:47:04 +1000] 401 -(192.168.1.248) GET /hello2?camera=front1 HTTP/1.1 (Wget/1.17.1 (linux-gnu))
[20/Apr/2019:20:47:05 +1000] 401 -(192.168.1.248) GET /hello2?camera=front1 HTTP/1.1 (Wget/1.17.1 (linux-gnu))
[20/Apr/2019:20:47:09 +1000] 401 -(192.168.1.56) GET /hello2?camera=frontstair HTTP/1.1 (Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36)

1 Like
#2

I have tried every name and password combination I can think of. Tried all the ones in the node-red config but still being rejected. Any ideas?

#3

19-04-22 07:17:42 INFO (MainThread) [hassio.auth] Auth request from a0d7b954_nodered for httpnode
19-04-22 07:17:43 WARNING (MainThread) [hassio.auth] Wrong login from httpnode

#4

I use http node to log into my cameras and grab snapshots. It works just fine.

#5

Yes it was working for me as well. It just stopped after I upgraded. However I may have had a sd card failure and have rebuilt the whole thing. Just spent the day installing stuff again so will see the next day or so.

I use it to get movement input from my Xoema cameras and then it marks the cctv foorgae with text so I can see what was going on when reveiwing the foorgae

#6

did a fresh install and still not working.

Using the name and password as in the config and the http port but refusing

19-04-24 05:19:02 INFO (MainThread) [hassio.auth] Auth request from a0d7b954_nodered for httpnode
19-04-24 05:19:04 WARNING (MainThread) [hassio.auth] Wrong login from httpnode

#7

Try clearing your local storage auth credentials. There was an issue like this for 3.0 of the node red addon. In Chrome Ctrl-Shift-J, application tab, local storage on the left, delete the stuff.

#8

Tried it from a completely different browser and same issue. Actually in an effort to get something I use it for going I thought about using a websocket node but it seems to have the same issue. Will keep working at it but its driving me crazy

#9

Out of interest is there a way of turning off the authentication so that it will simply let any request? I dont have my system exposed and only need to get a web request from my cctv server into node-red so authentication isnt a high requirement for me

#10

That depends on your camera server. Most of my hikvisions don’t require a login, but any of the newer firmware do.

#11

No I am using it the other way. My camera server has a http request into my node red. When it sees motion it sends a http request to the node-red. It normally passes the user and password in the http string but at the moment node-red is rejecting it. I used to use the httpnode username and password. Can I disable that part in node-red

#12

Then it’s not using an http node (which is a node INSIDE node-red)?

I am confused now.

I don’t have a username/password at all for node-red.

#13

Here is the link to the page I used to set it up originally. As mentioned I had it working

https://cookbook.nodered.org/http/create-an-http-endpoint

#14

OK, that makes sense.

Since you are using hassio, this is a configuration done on the node-red add-on, and not a normal node-red issue.

#15

Hey @Secs , wondering if you ever got this working? I’m trying my first httpIn for node-red addon, and I can’t even figure out what the base URL should be.

Thanks.

#16

Hi Rsrramirez.

I had it working beautifully. But I was a few upgrades behind and I went from .89 or simalar to 9 something in HA and it broke. For whatever reason it will not authenticate no matter what I use for username/password. I even did a fresh install of HA and get the same result so havent worked it out. Even using wget calling it from Linux command line gets a failure so not sure.
I come back and play every so often but have other bits and pieces I have been doing.
I followed https://cookbook.nodered.org/http/create-an-http-endpoint originally to get it going. I used it to have my CCTV system to pass data back to node-red

#17

Hi @Secs

From the previous post, since you were using HASSIO, I assume you’re using the node-red addon, yes? When it was working, what was the URL you were using? For example, in my stand-alone docker of node-red, I can get
http://hostname:1880/httpNodeName
to work
but if I use the node-red add on, I tried all different variations
eg
http://hostname:8123/api/hassio/addon/a0d7b954_nodered/httpNodeName
http://hostname:8123/api/addon/a0d7b954_nodered/httpNodeName
http://hostname:8123/hassio/addon/a0d7b954_nodered/httpNodeName

Just wondering.
Thanks.
-Roy

#18

Yes Roy you are correct. I am using Hassio and the addon. When it was working i was using the format http://httpnode:[email protected]:1880/hello2?camera=front2

and I called that from my linux box like

wget http://httpnode:[email protected]:1880/hello2?camera=front2

I was using the port of the node-red interface. I am just in the middle of a job in the house for she who must be kept happy but when thats finished I will have a play again

#19

Just tried it again. No luck either by using chrome in a web browser or linux via wget. Tried using the Hassio port or the one I have as an external to Node-red. Tried the httpnode username and password and also tried the username and password I log into Hassio with. It keeps getting an authentication failure