Hubspace integration failing to discover "entities" in my Account

Hi there, trying to configure Hubspace integration via HACS (v1.99) on my Home Assistant VM. I’ve added the following snippet to my “configuration.yaml” file, I’m not getting any recent errors/warnings in my log file since my last test on the latest HA Core/HAOS Update.


  - platform: hubspace
    username: !secret hubspace_username
    password: !secret hubspace_password
    debug: true


hubspace_username: myemail
hubspace_password: mypassword

I’m following the suggested method of keeping passwords and token in the encrypted “secrets.yaml” file - “Storing secrets - Home Assistant” I have tried placing the password directly into the “configuration.yaml” file instead, this unfortunately did not alter the outcome.

I’ve reloaded the configuration file, and tried rebooting the Home Assistant OS.

I’ve checked the states tap in developer tools for the entities, I’m trying to add a supported hubspace deadbolt from Homedepot via the Hubspace integration as a light entity so I can check it’s battery levels and toggle the lock from my HA Dashboard. I would also like to add the WAN/LAN Bluetooth Extension smart plug if possible.

the expected result is for the hubspace integration to automatically detect the entity’s as lights and add them to Home Assistant once account credentials are authenticated via the Hubspace API.

Initially I thought this was a bug but the developer over on github closed my issue and mentioned based on previous error logs it might be a password or configuration issue on my end, I’m 101% certain the credentials are indeed correct, so this must be a configuration issue on my side?

Hubspace integration failing to discover "entities" in my Account · Issue #67 · jdeath/Hubspace-Homeassistant · GitHub

Any help is greatly appreciated, thanks.