Hue emulator over remote subnet


I’m running Home Assistant on a google cloud instance, with a zerotier link to make things “look” local, like if I simply had it on a different subnet.

So far so good, it’s all working, but now I tried to setup emulated_hue to test some Alexa integrations and it’s not working. I’ve captured traffic on my phone while adding the bridge and I only see the app requesting the /config to the hass IP, receiving the response and… that’s all. Response is the json object defined in the source code, properly pointing to my zerotier IP and port 80. Any hints?

I’m assuming this is related to the lack of UPnP visibility between my wifi and the remote network but would like someone more experienced than me to confirm. If it’s the case, I’ll look for alternatives as messing with UPNP/IGD it’s not something I want to get into :slight_smile:


Hello again,

I sort of figured out the problem and it’s not related to multicast discovery (I setup smcroute on my gw). It looks like the Hue API changed, as well as the discovery method. UPnP/SSDP has been deprecated in favour of mDNS. Anyway, with manual IP discovery it’s not working either as the API seems to have changed.

I did slightly modify the python code on the component to match the /config response of a real Hue bridge I own but still not working and it keeps asking me to push the bridge button, even if the linkbutton is set to true. I might be of course doing something wrong!

@bdraco do you know if this is still working with the latest Hue App?


I don’t think it’s worked with the official hue app for a few years.

Oh! Then I’m doing it wrong. What’s the right way to pair it with Alexa? I thought the only way to have visibility over hue was via the app. Apologies if I missed it on the documentation!

I see, I need to ask Alexa to search for Hue lights, not bridges. I’ll try to make some progress on that front.

Got it working, thanks!!

By the way, would maybe be worth updating the documentation to make it clear how this should be configuring? I don’t think (again, maybe I missed it!) it’s stated anywhere that this is not configured through the app but using Alexa’s discovery instead.

Great job with this integration!