Hue integration not working on IoT vlan

I have my hue bridge on a separate IoT vlan. I just set up my HA on my default LAN. I can access the hue bridge on all my other devices from the LAN but I can’t access it from HA. When I switch the bridge back to my default LAN the integration is successful. Does anybody have advice on getting the hub to integrate while on the IoT vlan?

According to the documentation, the hue integration has iot class “local push”. Which means not only does HA need to be able to talk to it, it also needs to be able to talk to HA. Is your firewall set up to allow the Hue hub and HA to talk bidirectionally?

Currently it is not, I will try to open up the port in my firewall to allow the bridge to get through, see how that goes

So I tried to open up just the port for HA and that did not work, I had to open the entire IP address for the HA machine which worked, I don’t like opening up the entire IP to hue, wondering if there is a better way?

Sorry I’m not sure. The mechanism of communication between the two is determined by the implementation. I’m sure there is a way to restrict access further then the IP but to do so youd need to do some investigation. Either dig into the integrations implementation to figure out how they talk or do some network sniffing to see what’s passing between them.

I’ve never used that integration myself so I’m not sure how it works. My hue hub is somewhere in the basement, HA talks to my hue lights and remotes directly via zigbee.

I’m thinking about ditching the hub, in have some older hue bulbs are those ZigBee compatiable? Did you find it easy to set up the bulbs without the hub?

Yea pretty easy. I used the hub for like maybe a week then switched over to connecting them to HA using zigbee. Has been a couple years now and haven’t had any issues.

I do remember that you need the hub one last time to disconnect them from the hub and initiate the pairing process. Trying to factory reset the bulb without the hub is really difficult. You need to turn them off and on in a long and very precise sequence.

I just discovered the Hue vlan problem tonight. Also stopped my Kasa powerboards from working. Bugger.