Hue motion sensor triggered very ofthen

I have a Philips hue indoor motion sensor. Trigger is “sensor start detecting motion”, but I have also tried state with binary sensor “off” → “on”.

The problem with both setting is that the automation is triggered very often (~every other minute, as long there is motion).

How do I prevent “turning on” the lights over and over again?

type: motion
platform: device
entity_id: binary_sensor.kitchen_sensor_motion
domain: binary_sensor

service: light.turn_on
  brightness_pct: 100
  color_name: whitesmoke
  transition: 5

So you don’t want the light to be turned ON by the automation if its already ON?

Add a condition-

  - condition: state
    entity_id: light.your_light_name
    state: 'off'

That is correct!

Even if it works, it’s seems like a bit odd way to solve the problem?
What is the “normal” procedur/most common way to set up Hue indoor motion sensor, that not give tons of activations?

How long do you want to wait from the moment no motion is detected for turning off the lamp?

5 minutes. Turning off works fine, just the on commands over and over again, as long there is motion, which is unnecessary. But everything actually works fine, just the on-spamming that disturbing me.

platform: state
for: '00:05:00'
to: 'off'
entity_id: binary_sensor.kitchen_sensor_motion
from: 'on'

Not at all. The primary job of a motion sensor is to report motion when it occurs. How you use that information is independent of the sensor’s basic operation.

Some have a factory-set ‘cooldown’ (or ‘shutdown’) period where they won’t report they have detected motion if they just reported it less than X seconds/minutes ago. Battery-powered motion sensors tend to have longer cooldown periods in order to preserve battery-life. Mains-powered sensors can have a very short cooldown period (if any).

Depending on the intended application, this cooldown period can be an advantage or a disadvantage. A cooldown of 5 minutes would be a disadvantage if the goal is to promptly know when there’s no motion.

FWIW, all of my motion sensors are mains-powered so they have very short cooldown periods (and it’s not adjustable).

There is also the concept of an occupancy sensor. It instantly reports the first sign of motion, but it only reports ‘no motion’ after none has been detected for at least a minute (or more). For example, I sensors that report both motion (i.e. reports motion the moment it’s detected with a short cooldown period) and occupancy (i.e. reports no occupancy reported when there has been none for at least 1 minute). Effectively, that’s what you created when you added the option for: '00:05:00'

In my case, I have excluded all motion sensors from the recorder integration because I have no interest in seeing the history of motion events.