Hue Outdoor Motion Sensor on ZHA losing connection after years of working flawlessly

After years of working flawlessly, my Hue Outdoor Motion Sensor entity statuses suddenly changed to “unavailable” a few weeks ago.

Even though the battery had been showing 100% I checked the batteries, and they were fine. I removed the device from the network and re-paired, which appeared to work - but only for a few hours. Thinking that the device might be failing for some other reason I bought a second motion sensor. Same issue. The device appears to be on the network but if I check the temperature, it doesn’t change, which is a clue that it has stopped communicating. Eventually the statuses all change to unavailable.

I haven’t changed anything on my Home Assistant Yellow setup for months other than keeping up-to-date with all of the updates to the core, etc. as soon as they are made available. I see that there have been some updates to the Philips Hue Motion quirks code - about three weeks ago. Could that have introduced an issue? Also, the new entities allowing changes to sensitivity, and showing firmware status, etc. appeared. But I am out of my depth trying to understand whether those changes could be the culprit. Ditto using ZHA Toolbox to look under the hood.

Is anyone else having this sort of trouble? Does anyone have any ideas on how to figure out what is causing the problem? I am happy to supply any information I can.

The time is now 16:42 so the Zigbee network has not seen this device since 14:27. The temperature at least should be updating every few minutes as the sun goes down.

2 Likes

I had a similar problem some time ago, which affected my indoor motion sensors mainly, but also to a lesser extent the outdoor one. I found a discussion about the indoor sensors (SML001 and SML002) here and applied the fix suggested and it appeared to stabilize the outdoor one too. No problems since in any event. It’s a very simple change to configuration.yaml, easy to remove if it doesn’t work.

This solution seems to have fixed the problem with my original SML002 motion sensor, so thank you Stiltjack!

It is interesting though that I first tried the solution with my new “replacement” SML004 motion sensor - with no success. Is it possible that this more recent model is incompatible with Home Assistant? That would be a shame since there don’t seem to be any other Zigbee outdoor monitors on offer.

Just checked my outside sensor and it is indeed an SML002, sorry to have misled you. Can’t really help with SML004. I don’t see any mention at all on the ZHA device handler issues page in GitHub, so maybe it isn’t supported yet - you could put in a request.

No worrries. I have raised a ZHA integration issue and am communicating with Puddly and TheJulianJES.

I also have an SML004 with similar problems. Mine freaks out every six months and has to be factory reset and reinstalled. Very charming in between, but very frustrating when trying to figure out the minimum amount of work to get it working again, which turns out to be the maximum amount of work - every time (factory reset…). I really suspect the battery sensor doesn’t work. After two years of use, it still says 100%… No other motion sensor comes remotely close to that performance… :upside_down_face:

/F

TheJulianJES noticed that the firmware running in my Silicon Labs radio in my HA Yellow was out of date and he suggested I use the add-on Silicon Labs Flasher to update the firmware. After doing that I was able to add my SML004 without difficulty and it has been operating now for at least 6 hours. I feel like this firmware update has solved the issues I was seeing. Hooray :tada:

Just come across this thread after a search. I have exactly this issue: my Philips outdoor sensor (a SML004 model) has recently started becoming unavailable. I thought at first it needed new batteries, but they didn’t fix the problem.

When it becomes unavailable, I need to reset the sensor, and add the device again. Interestingly, it doesn’t get added as a new sensor, but picks up the existing details in HA.

I’m using a Home Assistant Sky Connect, which has the Silicon Labs EZSP chip in it. This is running firmware: 7.1.1.0 build 273. Does this need updating? (and if so, how can this be done?)