Hue plug/light unavailable, yet working, but not with HA

So with the decent changed in the hue component things are not working well anymore. I’ve some Osram plugs that most of the time are being displayed as unavailable. With Philips’ hue app or using Alexa or Google Home I can still turn those plugs on and of even if unavailable.

Now with HA they’re displayed as unavailable and I can’t do anything. In the past days I could still trigger an event with HA and they’d get turned on and off.

Is there a way to get that old behaviour back so that I can again control all of my hue devices even if marked as unavailable for some strange reason?

You need to add the option in your config:

allow_unreachable: true

2 Likes

Is this working? I have it on my config but still, lights randomly shows unavailable. I have the same situation as the original poster, my lights are unavailable on homeassistant and hue but I can still control it on hue.

Yes it does. Recently the “Hue component” has changed. I had to redo the setup, now everything worls fine:

hue:
  bridges:
    - host: YOUR-HUE-IP
      allow_unreachable: true

Weird, I have mine set to false so I shouldn’t be seeing unreachable status regardless of the state on the hue app/bridge. However, it doesn’t appear that way:

image

The gray ones reports unreachable/unavailable. I’m on 0.65.5

1 Like

In order to see them as available you need to set it to: true

1 Like

Let me try that option one more time, it was set to True after I updated to 0.65.

I guess that was the issue, I was thinking that option will enable the lights to report unreachable/unavailable on the status.

Unfortunately this doesn’t work for me. It’s still displayed as unavailable although I can control it using hue app.

Have you tried simply copy pasting (of course with the correct IP) exactly this above code into your config? There has been a change in how the component works. I was not able to use any other way of writing it.

Ha! Thx. I didn’t notice the slightly changed configuration. It works now.

whoever decided on the language of “allow unreachable: true” made it confusing, seeing as lots of people think setting it to false would not display “unreachable” in place of the toggle. True should be false and false should be true.

1 Like

there s more to it than only showing the switch in Hassio frontend.

When checking the lights in a python script, the setting False makes it discard the unreachable lights and thus enabling a correct operation of the python script. If it were set to True, the python script just sees the unavailable lights as available and even On if that was the setting the lights where before becoming unavailable. It would display these lights in the frontend as being there, while in fact they are not.

Allow_unreachable: false therefor is an essential option for the Hue implementation, and , since there’s no option for it in the new discovery option (at least not documented) reason enough to disable discovery on the philips_hue in config, and have it imported by manual configuration as per above settings, albeit with setting False :wink:

as always ymmv…

cheers,
Marius

While your reply makes sense, I still have an issue with intermittent hue light operation and constant logging of “unavailable” lights even with Allow_unreachable set to false. I really don’t see a difference when changing false to true.

This used to work flawlessly and I’ve bought into Hue lights big time, so this is really frustrating. I’ve posted elsewhere with no response so either it’s only an issue I have or no one seems to know how to fix it or care to fix it.

I’m running 0.70 on a NUC with discovery disabled. I have manually configured Hue. I litterally have a log entry every 2 minutes for each light:

For example, it will say “Bathroom turned off” and then immediately log “Bathroom is unavailable” when I haven’t done anything to that particular light or manually turned it on/off.

i hear you, and agree mostly. Was working before and the new implementation caused many issues. it is getting better though after a few iterations of Hassio. As of 070.1 the hue scenes seem to be working again:

script:
  set_hue_scene:
    alias: Set Hue scene
    sequence:
      - service: hue.hue_activate_scene
        data_template:
          group_name: '{{ states.input_select.hue_groups.state }}'
          scene_name: '{{ states.input_select.hue_scenes.state }}'

the constant flapping seems to have decreased, though still happening indeed.

Your investment in Hue devices isn’t gone though, since the dedicated Hue app has improved a lot, and is working very robustly. Never a hickup there.

Having said that, i most sincerely hope the integration with Hassio will be restored fully very soon. My only way of assisting in that process is trial and report back.

Cheers,
Marius

A BIG THANK YOU!

Since the new usage of the api v2 it seems that either the property allow_unreachable: true has no longer an effect or at least does not what it should, therefor my OSRAM plugs are mostly unavailable within home assistant but can be controlled via hue app. Inside of hue app they are marked as unavailable.

I have the same issue with Osram in Hue. Does anyone jnow how to deal with “unreachable” now?

Any workaround available until fixed? This is really a problem, that I can no longer control several components of my home…

Just solved it using the UI by going to Configuration > Integrations > Philips hue - Click “CONFIGURE”. Select the entity in the “Ignore connectivity status for the given devices” option.

grafik

4 Likes