Hue Thief and

Is it possible to use Hue Thief on a pi running Any help would be greatly appreciated. Thanks!

Any help? I have some hue lights that are unusable at the moment.

Has anyone done this?

I was looking into this as well but I don’t think it’s possible to run Hue Thief on your Pi that hosts Hassio. first you need install git and pip packages, which I’m not sure you can do, even with root access to Hassio.

I’m trying to run Hue Thief on my Windows laptop. If I succeed, I’ll post the instructions here. Don’t get your hopes up though.

I got it working using an Ubuntu VM! I may write a full tutorial for this later, but here is the gist of it. I used a Nortek/GoControl Z-Wave & Zigbee USB Adapter - Model HUSBZB-1 and my Windows laptop. Sorry for lack of details, but you will need to be familiar with setting up Virtualbox VMs and

  • Download Virtualbox
  • Download the latest Ubuntu Virtualbox hard disk image from
  • Create an Ubuntu VM using the downloaded image as the hard disk
  • Log into Ubuntu as user and pw:
  • Open ‘Terminal’ app, and download the programs ‘git’ and ‘python3-pip’. Do this by typing ‘sudo apt-get install git’ and ‘sudo apt-get install python3-pip’
  • Download the hue-thief script by typing ‘git clone
  • Install any required dependencies for hue-thief by typing ‘cd hue-thief’, then ‘pip3 install --user -r requirements.txt’

Everything should now be installed on the VM to start running the script. Next, you will need to connect your Zigbee USB adapter and run the script.

  • Place the Philips Hue light you wish the flash closer to the Zigbee adapter
  • Turn off your Raspberry Pi running Home Assistant and remove your Zigbee USB adapter
  • plug your Zigbee USB adapter into your computer
  • Remove any unnecessary USB devices currently connected to your computer
  • In the bottom right corner of the running VM, click on the USB device icon and select the Zigbee device. It may have an odd name, like ZControl something.
  • Open the Terminal again and go to the \hue-thief\ directory that downloaded from the previous step
  • run the command ‘sudo python3 /dev/ttyUSB1’ . For my GoControl adapter, it was using USB1 instead of USB0 stated on the hue-thief github page.
  • the script should start running instantly and announce that it is scanning channels. If the script is running but no text is displayed, try a different /dev/ttyUSB number, like 1,2,3.
  • The Philips Hue light should start blinking and a prompt will appear, asking you if you want to reset the bulb. type ‘y’ to reset
  • That’s it
1 Like

Thank you so much! I got it working!

I tried to run it on a fresh install of NOOBS on a Raspi 3B+ also using a HUSBZB I got "ImportError: No module named ‘pure_pcapy’

I ran pip iinstall pure_pcapy and it appeared to install. However, the install looks to be pure-pcapy and the error is pure_pcapy.

I’m out of my element here and am not sure it makes a difference, but it’s not running. Thoughts? Ideas?

I would really like to reset my Hue bulbs…

Did you ever resolve this? I am getting the same error.

I never got it working. Ended up using the dimmer method to reset the Hue bulbs. In the end Hue and Sengled bulbs both working with HA and a HUSBZB on a RPI 3. Range is decent. Hue bulbs will repeat to Sengled bulbs.

Hi dwinnn, I’ve been trying to make your method work, but everytime I start the scan, the script (and terminal) seem to crash. White box appears, nothing else. I have to restart terminal to retry.

Do you have an idea what I am doing wrong?

Sorry, no idea what’s wrong. I was able to run Hue Thief on two separate occasions and it worked.

However I would really advise you not to pair Hue bulbs this way and use the Hue bridge instead. You will get headaches trying to unpair and pair to another hub. Or if your current hub dies and you want to connect the bulbs to another hub, I don’t think you can do it. I think the Hub bulb pairing process only works with the Hue bridge–there’s no documented method of turning the power on/off x number of times that will get the bulb into pairing mode.

I ran into this error too and the error was due to mixing commands with and without sudo, as the dependencies get installed to the current user not the super user (which you then maybe trying to run the command as)