HUSBZB-1 issues and reliability

Tags: #<Tag:0x00007fc407741990>

I remember seeing Nortek/Linear Gocontrol HUSBZB-1 on the list of supported controllers (or am I dreaming?) at https://www.home-assistant.io/docs/z-wave/controllers/, but I dont see it anymore or was it never there?

I am planning to buy a z-wave stick but considering HUSBZB-1 supports both z-wave and zigbee, I was more inclined towards it. Although looking at the number of issues reported in the community, I am not too fond of it anymore. Any suggestions? Should consider other controllers like Aeotec/ZWave/Zooz?

Thanks

I have that stick with no issues. I remember seeing that it is discontinued so that may be why it was dropped from the list.

Interesting it is still listed here.

I got one a few months ago, it’s been working fine. I see they’re still sold on Amazon, NewEgg and eBay.

What’s this about discontinued? I hope HA isn’t dropping support for them. Even if they do stop selling them someday, there will still be an installed base!

I thought I saw that on a Nortek page after I got mine. It looks like it may be sold under their Gocontrol name too.

I have one and up until a few versions ago it worked fine for over a year. I didn’t know they were discontinued.

I found this thread searching for a resolution to my issues. Perhaps it will ring a bell with someone.
Currently I run Hass.io on a RPi 3B+ with the HUSBZB. The issue is that my ZigBee lights are being forgotten regularly. Sometimes it can be corrected by cycling the bulbs power. Other times it requires re-adding them thru the ZHA configuration routine.

I’ve read where ZHA is going thru some major changes and others have complained of the same thing. I had hoped it would have been cleared up by now. I recently went to v.92.1 and 92.2 but downgraded back to 91.4 due to other problems.

Is there a better way to bridge to ZigBee? Has anyone else had this happen?

I’m still not convinced they’re discontinued. They’re still for sale from a number of vendors, including Amazon.

I also run Hass.io on a RPi 3B+ with the HUSBZB-1. I just updated to 0.92.2, so after reading this I checked all my Zigbee devices. I have three Visonic door/temperature sensors, one Sylvania smart plug and two Ikea Tradfri smart plugs. All have been working normally since the upgrade. If anything, I’ve found the Zigbee implementation to get even more reliable over the past few months. At first the battery level on the Visonic devices didn’t always show up, but I haven’t noticed that lately. Otherwise, this configuration has been rock-solid.

1 Like

I was sure Nortek showed them as discontinued but I cannot find that page now. I had seen it after I got mine late last year.

After this latest Wink issue I really need to work on getting away from it… anyone have any info on the range of the HUSBZB-1? My NUC is in the basement and I have concerns it’s not going to reach my garage without issue.

Depending on the placement of your NUC you could use a USB extension to better position the USB stick.

Hey guys,
After setting up my system with the Aeotec usb i decided i wanted to be able to control zigbee devices as well and picked up the HUSBZB-1 (US version) and i cannot figure out how to include or add a node. When i check the log it looks like it starts searching then just gets lazy and says there is nothing to do within a second. I’ve tried having someone else click the button while i tap my mono price muti sensor 2 times and nadda. I also have some zwave dimmers (GE,Honeywell) and they dont see to do anything either. with Aeotec you just had to push the button on the stick and walk around and touch each device to get it paired then in HA they would just show up under integrations>Zwave.

Here is the output when I add a device. anyone who has this working, I would appreciate if you could post the log of a device actually being included/. added.

After going to Z-Wave Network Management > then clicking ADD NODE SECURE (I put a randome network key in my config) and this is the log. same with the plain ADD NODE

2019-11-22 16:16:10.606 Detail, contrlr, Queuing (Command) Add Node Stop: 0x01, 0x04, 0x00, 0x4a, 0x05, 0xb4
2019-11-22 16:16:10.606 Detail, Notification: ControllerCommand - Canceled
2019-11-22 16:16:10.608 Detail,
2019-11-22 16:16:10.609 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x4a) - Add Node Stop: 0x01, 0x04, 0x00, 0x4a, 0x05, 0xb4
2019-11-22 16:16:10.666 Detail, contrlr, Received: 0x01, 0x07, 0x00, 0x4a, 0x14, 0x06, 0x00, 0x00, 0xa0
2019-11-22 16:16:10.666 Detail,
2019-11-22 16:16:10.666 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:
2019-11-22 16:16:10.666 Info, contrlr, ADD_NODE_STATUS_DONE
2019-11-22 16:16:10.666 Detail, Node006, Expected reply was received
2019-11-22 16:16:10.666 Detail, Node006, Message transaction complete
2019-11-22 16:16:10.667 Detail,
2019-11-22 16:16:10.667 Detail, contrlr, Removing current message
2019-11-22 16:16:10.667 Detail, Notification: ControllerCommand - Completed
2019-11-22 16:16:12.698 Detail, Queuing (Controller) Add Device
2019-11-22 16:16:12.698 Info, Add Device
2019-11-22 16:16:12.698 Detail, contrlr, Queuing (Command) ControllerCommand_AddDevice: 0x01, 0x05, 0x00, 0x4a, 0xc1, 0x15, 0x64
2019-11-22 16:16:12.698 Detail, Notification: ControllerCommand - Starting
2019-11-22 16:16:12.700 Detail,
2019-11-22 16:16:12.700 Info, contrlr, Sending (Command) message (Callback ID=0x15, Expected Reply=0x4a) - ControllerCommand_AddDevice: 0x01, 0x05, 0x00, 0x4a, 0xc1, 0x15, 0x64
2019-11-22 16:16:12.704 Detail, contrlr, Received: 0x01, 0x07, 0x00, 0x4a, 0x15, 0x01, 0x00, 0x00, 0xa6
2019-11-22 16:16:12.704 Detail,
2019-11-22 16:16:12.704 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:
2019-11-22 16:16:12.704 Info, contrlr, ADD_NODE_STATUS_LEARN_READY
2019-11-22 16:16:12.704 Detail, Node001, Expected callbackId was received
2019-11-22 16:16:12.704 Detail, Node001, Expected reply was received
2019-11-22 16:16:12.704 Detail, Node001, Message transaction complete
2019-11-22 16:16:12.704 Detail,
2019-11-22 16:16:12.704 Detail, contrlr, Removing current message
2019-11-22 16:16:12.704 Detail, Notification: ControllerCommand - Waiting
2019-11-22 16:16:12.705 Info, WriteNextMsg Controller nothing to do

You say you replaced an Aeotec. Were the devices you are trying to add now already included on that controller. If so, did you exclude them yet?

Most importantly… what @freshcoast said… did you exclude them from the old network?? also you could share your config… usb_path did you add a secure key etc… some of that info could help… I have an husbzb-1 and it has been working great… no complaints whatsoever… any issues that arose were either device related or a messed up OZW update that put the wrong version on once… the stick itself has been excellent.

It actually doesn’t matter which stick you exclude from. Sometimes devices come from the factory included into another network (maybe for testing purposes), and adding them seems to not work. The solution there is to remove then add.

I didn’t say it mattered which stick… but if they were associated with the old network… well… semantics… :slight_smile:

Hey guys thanks.

I lost my old setup with the devices connected to the aeotec and was able to push the up and down paddles 5 times each and saw the blue light flash on my GE and Honeywell light switches. I also tapped the pin hole 10 times to default the monoprice sensor. When I press the button on the aeotec to pair it did stop flashing when I tapped the one light switch. I will work on getting my old one set back up or just use the aeotec to see if that at least works when I get back.

I’m not at my PC right now but here is a screen shot. I copied the network key from some other post. Does it have to be specific not my environment?

okay so i was able to plug my aeotec back in and set it up in the config and was able to select remove node and got a few off so far and they were then connected to the HUSBzB-1

I think its going to work. thanks for helping get to that troubleshooting step.

Also I like that the HUSBZB-1 works in the USB port on the Pi4 unlike the Aeotec that needs a USB 2.0 hub connected.

Thanks!!!

Like he said up there the stick didn’t matter… you should have been able to exclude with either stick… I’ve ran into devices that are very difficult but googling the instructions can sometimes find another “hard reset” if the normal exclusion doesn’t work… it is just sometimes poorly documented. You may have to exclude multiple times with the device close to the stick…

Did you find a solution to this. My Zigbee devices were working fine until I added a Zwave device.

All, looking to add the GoControl HUSBZB-1 to my HA setup, so I have more visibility to my Zigbee and Z-wave devices and HA control and access.

Wondering a couple of things:

  • Would you recommend this USB Dongle over others out there? I like being able to support both Zigbee and Z-wave

  • I’m running my HASS on a VM. If I’m able to access the USB device on the VM, do I just configure HASS and I don’t need any other software to support it?

  • Any other pointers would be appreciated.

Thanks!

This is the only one I have any experience with, and it’s been working flawlessly since my earlier post, above. (Two years ago now!) I’ve added a number of Zigbee devices since then, and have nothing but good things to say about the whole Zigbee side of my HA setup. I was thinking of trying out some Z-wave stuff, but Zigbee devices are working out so well I’ve never bothered.