HUSBZB-1 problems


#1

I installed Home Assistant into Raspian using directions from https://home-assistant.io/docs/installation/virtualenv/

The web interface is up.

Then I plugged in a HUSBZB-1 zwave & zigbee USB stick. Because I want to get rid of my SmartThings hub and use Home Assistant.

I added this to my configuration.yaml file:

HUSBZB-1 zigbee/-wave USB stick

zwave:
usb_path: /dev/ttyUSB0
zha:
device: /dev/ttyUSB1
database_path: /config/zigbee.db

In the directory /home/homeassistant/.homeassistant/ there is no zigbee.db file, but there is a home-assistant_v2.db file and despite the changed db file name, it still isn’t recognized.

I ran a Check Config and here is the summary:
Failed config General Errors:

  • Component not found: usb_path
  • Setup failed for usb_path: Component not found.
  • Component not found: device
  • Setup failed for device: Component not found.
  • Component not found: database_path
  • Setup failed for database_path: Component not found.

#2

You need to change device to usb_path. If you know your USB paths are correct (probably so if it’s the only USB device you have, but may change if you plug in anything else) and you want your zigbee database alongside your HASS database, then your config should look like

zwave:
  usb_path: /dev/ttyUSB0

zha:
  usb_path: /dev/ttyUSB1
  database_path: /home/homeassistant/.homeassistant/zigbee.db

The logs also suggest it’s trying to set up usb_path, device, and database_path as separate components, so make sure they’re properly indented.


#3

Thank you for the reply. Your recommendations were very helpful Zwave is now showing up under Domains, but still no zigbee. There’s been progress and I need to walk my dog, which is my way of walking away from the tech so that it doesn’t become a burden. I’ll be back.

Here’s what I did:

  • indent (duh)
  • changed zigbee device: to usb_path: (stupid of me)
  • checked config and it was valid
  • reloaded Core, but now zwave
  • restarted Pi and took a biological break
  • zwave is now under Domains

ZHA Zigbee Tested Devices...Please add your device results
#4

ZHA doesn’t show up in the frontend like zwave does. Go to the services menu (in the sidebar, under Developer Tools, it’s the farthest left icon). Under the domain drop down, you should have an entry called zha (not zigbee). If it’s not there and you’re sure you’ve corrected your configuration.yaml, check the logs. It will tell you why zha isn’t loading.


#5

Ah, the little things that make a difference, such as a space in the db path. Thank you for the reply and help. I can now see both zha and zwave under Domains. My journey with Home Assistant starts today.


#6

No worries. I actually just got the same adapter yesterday and didn’t realize there was a difference between zigbee and zha until I saw this post. It’s a learning experience the whole way.


#7

Any luck getting zwave devices to show up? I’ve tried pairing my aeotec recessed sensors, and nothing happens after clicking add node.