Husqvarna Automower installation (connection with HA)


I try to install the Husqvarna Automower integration =>

I have to set 3 fields : 36 digits API Key, Username, Password.
I create all the application in Husqvarna Developer Portal and add Authentication API and Automower Connect API to this app.
I can’t connect and have always the same error

(Sorry it’s french)

When i try to connect with SSH console, it’s work…


Thank you :slight_smile:

I got that integration working a long time now.

Its simply create an account on Developer Portal and follow the instructions from

Enter your API key, username and password and your good to go!

Could you post any log files so we can figure it out?

Thank you for your response.
Here my husqvarna Application screen :

I use Application Key, Email and Password to login in HA
“Automower Connect API” and “Authentication API” are available in my Application.

When I try the curl command line into my SSH Console, that’s works…

I don’t understand -_-’

Stupid question maybe… but is your mower in the supported list??
Can you control your mower with the husqvarna app?

Because the integration works like a charm. Just enter the api-key, email and password and everything will be sorted for you.

Maybe a reboot of HA is in place?

I have an Automower 450X (he is in the list) and I use the “Automower Connect” app on my Iphone. I already restart many time HA (for other updates)…

But for the moment, my automower is not connected to my Developper Account ! Tha’t maybe the problem ? no ?

I used the same account for my mower as for the developer portal.

I dont know if you solved it yet.

Just now I upgraded HA to its latest version and yes my Husqvarna integration asked to give it a bit of attention.

I created a new application on the developers portal of Husqvarna

Name: Whatever you want.
Redirect Url: Link to OAuth2 Authorize Callback – My Home Assistant

Connected API’s:

  • Authentication API
  • Automower Connect API

Deleted the existing integration from my HomeAssistant and re-installed it, no reason but just felt better to do.

Provided the information the integration needed. Name (the one you gave it on the developers portal), Key and Secret (both generated on the developers portal). Saved and was redirected to the developers portal of Husqvarna. After that authorize your set and your done!

Hope this helps you.

Hi, i have integrated my Husqvarna automover 405X but i dont get entities in HA. Schermafbeelding 2023-06-16 om 14.41.18

this is my debug log:

Logger: homeassistant.config_entries
Source: helpers/
First occurred: 16:51:57 (17 occurrences)
Last logged: 16:58:45

Error unloading entry husqvarna_automower for number
Error unloading entry husqvarna_automower for select
Error unloading entry husqvarna_automower for sensor
Error unloading entry husqvarna_automower for vacuum
Error unloading entry husqvarna_automower for camera
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 543, in async_unload
    result = await component.async_unload_entry(hass, self)
  File "/usr/src/homeassistant/homeassistant/components/camera/", line 426, in async_unload_entry
    return await component.async_unload_entry(entry)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 194, in async_unload_entry
    raise ValueError("Config entry was never loaded!")
ValueError: Config entry was never loaded!

Are there any earlier logs? The integration never loaded, so it fails to unload. We would need to see why the integration failed to load to really provide any guidance.

Im trying to install this for the first time. I have successfully created the Husqvarna API part. But when I try to add the Integration to Home Assistant, it takes a very long time, and then I get error code 500 Internal Server Error.

Looking at some logs I found this: I don’t know it it has anything to do with it all?

homeassistant.requirements.RequirementsNotFound: Requirements for husqvarna_automower not found: [‘Shapely>=1.8.2’].

i hade a old robot in HA, SO i delet the it all, and did a new install using the guide.
I works to the point i install from HACS and is sending me to HQ page, i gett error.
It sems that my old api-key are still in, some how.
I have delet the old robot in hq page. But still sending me to the old.

I have restart after delet, restart after install and, clear the chaes on the brower.
Any good advice?

Did you delete the application credentials entry?