Huzzah + Neopixel no workie

I’ve got ESPHome working on a handful of Adafruit Huzzah ESP8266 boards, and I already have a DHT22 wired up GPIO5 and working wonderfully.

I’m trying to add a NeoPixel Stick. Now, I’ve seen the note in the documentation about using GPIO3, but the huzzah board doesn’t seem to break out GPIO3.

Moreover, I can’t for the life of me, get the neopixel stick to even light up, at all. (I’ve verified it’s in good working order with an esp32)

I’ve tried both the neopixelbus and the fastled_clockless. With the neopixelbus I’ve tried almost every variant. Though the product page specifically states it’s either using WS2812 or SK6812, yet neither work.


# wsn02

  devicename: wilresssensornode02
  shortname: wsn02
  shortupper: WSN02

  name: "${shortname}"

<<: !include common/common.yaml

  board: huzzah

# Enable Home Assistant API
  password: !secret api_wsn02

  - platform: dht
    pin: GPIO5
    model: DHT22
      name: "$shortupper Temperature"
        - lambda: return x * (9.0/5.0) + 32.0;
      unit_of_measurement: "°F"
      name: "$shortupper Humidity"
    update_interval: 60s

  - platform: neopixelbus
    type: GRBW
    pin: GPIO2
    num_leds: 8
    variant: WS2812
    name: "$shortname Light"    
      - addressable_scan:
      - addressable_color_wipe:
      - addressable_rainbow:
      - addressable_fireworks:


INFO Reading configuration /config/wsn02.yaml...
INFO Generating C++ source...
INFO Compiling app...
Processing wsn02 (board: huzzah; framework: arduino; platform: platformio/espressif8266 @ 3.2.0)
HARDWARE: ESP8266 80MHz, 80KB RAM, 4MB Flash
LDF: Library Dependency Finder ->
Dependency Graph
|-- ESPAsyncTCP-esphome @ 1.2.3
|-- ESPAsyncWebServer-esphome @ 2.1.0
|   |-- ESPAsyncTCP-esphome @ 1.2.3
|   |-- Hash @ 1.0
|   |-- ESP8266WiFi @ 1.0
|-- ESP8266WiFi @ 1.0
|-- ESP8266mDNS @ 1.2
|-- ArduinoJson @ 6.18.5
|-- NeoPixelBus @ 2.6.9
|   |-- SPI @ 1.0
Compiling .pioenvs/wsn02/src/main.cpp.o
Linking .pioenvs/wsn02/firmware.elf
RAM:   [====      ]  40.9% (used 33540 bytes from 81920 bytes)
Flash: [====      ]  44.3% (used 462537 bytes from 1044464 bytes)
Building .pioenvs/wsn02/firmware.bin
esp8266_copy_factory_bin([".pioenvs/wsn02/firmware.bin"], [".pioenvs/wsn02/firmware.elf"])
========================= [SUCCESS] Took 13.80 seconds =========================
INFO Successfully compiled program.
INFO Resolving IP address of
INFO  ->
INFO Uploading /config/.esphome/build/wsn02/.pioenvs/wsn02/firmware.bin (466688 bytes)
INFO Compressed to 319240 bytes
Uploading: [============================================================] 100% Done...

INFO Waiting for result...
INFO OTA successful
INFO Successfully uploaded program.
INFO Starting log output from using esphome API
WARNING Can't connect to ESPHome API for Timeout while connecting to ('', 6053)
INFO Trying to reconnect to XXX in the background
INFO Successfully connected to XXX
[20:24:21][I][app:102]: ESPHome version 2022.12.3 compiled on Dec 27 2022, 20:23:15
[20:24:21][C][wifi:504]: WiFi:
[20:24:21][C][wifi:362]:   Local MAC: XXXXXXXXXXX
[20:24:21][C][wifi:363]:   SSID: [redacted]
[20:24:21][C][wifi:364]:   IP Address: XXXXXXX
[20:24:21][C][wifi:365]:   BSSID: [redacted]
[20:24:21][C][wifi:367]:   Hostname: 'wsn02'
[20:24:21][C][wifi:369]:   Signal strength: -57 dB ▂▄▆█
[20:24:21][C][wifi:373]:   Channel: 10
[20:24:21][C][wifi:374]:   Subnet:
[20:24:21][C][wifi:375]:   Gateway: XXXXXXX
[20:24:21][C][wifi:376]:   DNS1:
[20:24:21][C][wifi:377]:   DNS2:
[20:24:21][C][logger:293]: Logger:
[20:24:21][C][logger:294]:   Level: DEBUG
[20:24:21][C][logger:295]:   Log Baud Rate: 115200
[20:24:21][C][logger:296]:   Hardware UART: UART0
[20:24:21][C][light:104]: Light 'wsn02 Light'
[20:24:21][C][light:106]:   Default Transition Length: 1.0s
[20:24:21][C][light:107]:   Gamma Correct: 2.80
[20:24:21][C][dht:017]: DHT:
[20:24:21][C][dht:018]:   Pin: GPIO5
[20:24:21][C][dht:024]:   Model: DHT22 (or equivalent)
[20:24:21][C][dht:027]:   Update Interval: 60.0s
[20:24:21][C][dht:029]:   Temperature 'WSN02 Temperature'
[20:24:21][C][dht:029]:     Device Class: 'temperature'
[20:24:21][C][dht:029]:     State Class: 'measurement'
[20:24:21][C][dht:029]:     Unit of Measurement: '°F'
[20:24:21][C][dht:029]:     Accuracy Decimals: 1
[20:24:21][C][dht:030]:   Humidity 'WSN02 Humidity'
[20:24:21][C][dht:030]:     Device Class: 'humidity'
[20:24:21][C][dht:030]:     State Class: 'measurement'
[20:24:21][C][dht:030]:     Unit of Measurement: '%'
[20:24:21][C][dht:030]:     Accuracy Decimals: 0
[20:24:21][C][status:034]: Status Binary Sensor 'WSN02 Status'
[20:24:21][C][status:034]:   Device Class: 'connectivity'
[20:24:21][C][version.text_sensor:021]: Version Text Sensor 'WSN02 Version'
[20:24:21][C][version.text_sensor:021]:   Icon: 'mdi:new-box'
[20:24:21][C][restart.button:017]: Restart Button 'WSN02 restart'
[20:24:21][C][safe_mode.button:022]: Safe Mode Button 'WSN02 safe mode'
[20:24:21][C][safe_mode.button:022]:   Icon: 'mdi:restart-alert'
[20:24:21][C][web_server:125]: Web Server:
[20:24:21][C][web_server:126]:   Address: XXXXXXXXX:80
[20:24:21][C][mdns:103]: mDNS:
[20:24:21][C][mdns:104]:   Hostname: wsn02
[20:24:21][C][ota:093]: Over-The-Air Updates:
[20:24:21][C][ota:094]:   Address: XXXXXXXXXXXX:8266
[20:24:21][C][api:138]: API Server:
[20:24:21][C][api:139]:   Address: XXXXXXXXXXXX:6053
[20:24:21][C][api:143]:   Using noise encryption: NO
[20:24:22][C][wifi_info:009]: WifiInfo IPAddress 'WSN02 IP'
[20:24:42][D][api:102]: Accepted XXXXXXXX
[20:24:42][W][api.connection:083]: Home Assistant 2022.12.8 (XXXXXXX): Connection closed
[20:24:59][D][dht:048]: Got Temperature=22.3°C Humidity=27.8%
[20:24:59][D][sensor:126]: 'WSN02 Temperature': Sending state 72.14000 °F with 1 decimals of accuracy
[20:24:59][D][sensor:126]: 'WSN02 Humidity': Sending state 27.80000 % with 0 decimals of accuracy

What am I missing here, I’ve spent hours with 0 progress.