HX711 is not ready for new measurements yet!

I inadvertently messed some things up on my network and didnt have a backup, so I had to rebuild some of my ESPhome items by scratch. This was just working the other day, so I know the hardware is still good. I loaded an old bin and saw the scale device was returning results.

I’m running ESPhome as a docker container, so I’m not using the internal version. This device is another “bed scale” type. My yaml:

esphome:
  name: mbr-bed-hx711
  friendly_name: mbr-bed-hx711
  includes:
    - "custom_hx711.h"
  libraries:
    - "https://github.com/bogde/HX711"

esp8266:
  board: d1_mini
  
# Enable logging
logger:

wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password
  fast_connect: true

  manual_ip:
    static_ip: 172.16.68.114
    gateway: 172.16.68.1
    subnet: 255.255.255.0

# Enable Home Assistant API
api:
  encryption:
    key: "s9er2MrsYpXCTTGFaZpLS259fhLdshlzRCJWr#####="

ota:
  password: "72ceacf5abedc1928aa004b86#####"

sensor:
  - platform: hx711
    name: "HX711 Value"
    dout_pin: D1
    clk_pin: D2
    gain: 128
    accuracy_decimals: 3
    update_interval: 0.5s

and here is the log:

INFO ESPHome 2024.5.0
INFO Reading configuration esphome/mbr-bed-hx711.yaml...
INFO Starting log output from 172.16.68.114 using esphome API
INFO Successfully connected to mbr-bed-hx711 @ 172.16.68.114 in 0.008s
INFO Successful handshake with mbr-bed-hx711 @ 172.16.68.114 in 2.686s
[23:45:28][I][app:100]: ESPHome version 2024.5.0 compiled on May 15 2024, 23:41:29
[23:45:28][C][wifi:580]: WiFi:
[23:45:28][C][wifi:408]:   Local MAC: B4:E6:2D:3C:A8:53
[23:45:28][C][wifi:413]:   SSID: 'mySSID'[redacted]
[23:45:28][C][wifi:416]:   IP Address: 172.16.68.114
[23:45:28][C][wifi:419]:   BSSID: FF:FF:E0:17:E5:65[redacted]
[23:45:28][C][wifi:421]:   Hostname: 'mbr-bed-hx711'
[23:45:28][C][wifi:423]:   Signal strength: -55 dB ▂▄▆█
[23:45:28][C][wifi:427]:   Channel: 1
[23:45:28][C][wifi:428]:   Subnet: 255.255.255.0
[23:45:28][C][wifi:429]:   Gateway: 172.16.68.1
[23:45:28][C][wifi:430]:   DNS1: 0.0.0.0
[23:45:28][C][wifi:431]:   DNS2: 0.0.0.0
[23:45:28][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:28][C][logger:185]: Logger:
[23:45:28][C][logger:186]:   Level: DEBUG
[23:45:28][C][logger:188]:   Log Baud Rate: 115200
[23:45:28][C][logger:189]:   Hardware UART: UART0
[23:45:28][C][hx711:021]: HX711 'HX711 Value'
[23:45:28][C][hx711:021]:   State Class: 'measurement'
[23:45:28][C][hx711:021]:   Unit of Measurement: ''
[23:45:28][C][hx711:021]:   Accuracy Decimals: 3
[23:45:28][C][hx711:021]:   Icon: 'mdi:scale'
[23:45:28][C][hx711:022]:   DOUT Pin: GPIO5
[23:45:28][C][hx711:023]:   SCK Pin: GPIO4
[23:45:28][C][hx711:024]:   Update Interval: 0.5s
[23:45:28][C][mdns:115]: mDNS:
[23:45:28][C][mdns:116]:   Hostname: mbr-bed-hx711
[23:45:28][C][ota:096]: Over-The-Air Updates:
[23:45:28][C][ota:097]:   Address: 172.16.68.114:8266
[23:45:28][C][ota:100]:   Using Password.
[23:45:28][C][ota:103]:   OTA version: 2.
[23:45:28][C][api:139]: API Server:
[23:45:28][C][api:140]:   Address: 172.16.68.114:6053
[23:45:28][C][api:142]:   Using noise encryption: YES
[23:45:29][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:29][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:30][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:30][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:31][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:31][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:32][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:32][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:33][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:33][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:34][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:34][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:35][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:35][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:36][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:36][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:37][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:37][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:38][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:38][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:39][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:39][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:40][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:40][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:41][W][hx711:037]: HX711 is not ready for new measurements yet!
[23:45:41][W][hx711:037]: HX711 is not ready for new measurements yet!

Is the update too fast at every 1/2 second, default is 60 seconds. The only difference with your config and mine is the gain is 64 and a 30 sec update time. Are you sure about the pin assignment having lost the original sketch?

Fairly sure. Would you mind sharing your yaml so I can run a diff on my end?

I commented out the filters. They are for calibration and to change the weight to gallons, it’s not needed for setup.

  - platform: hx711
    name: "grow_res_level"
    dout_pin: GPIO14
    clk_pin: GPIO12
    gain: 64
    update_interval: 30s
    # filters:
    #   - calibrate_linear:
    #     - -8800 -> 0
    #     - 46458 -> 10
    #     - 98943 -> 20
    #     - 156723 -> 30
    #     - 210661 -> 40
    #     - 237000 -> 50
    #   - quantile:
    #       window_size: 7
    #       send_every: 4
    #       send_first_at: 3
    #       quantile: .9
    #   - offset: -2.0
    #   - lambda: return x / 8.345;
    # unit_of_measurement: gal
    accuracy_decimals: 3
    force_update: true

Thanks, but could you share the entire yaml, redacted where appropriate? I’m having a day with this and want to make sure bits 100%

esphome:
  name: light-and-air-quality
  platform: ESP8266
  board: esp01_1m

# Enable logging
logger:
#  level: VERY_VERBOSE

# Enable Home Assistant API
api:

ota:
  password: 
wifi:
  ssid: "iot"
  password: 
  manual_ip:
    static_ip: 192.
    gateway: 192.
    subnet: 255.255.255.0


  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "Light-And-Air-Quality"
    password:
    
#time:
#  - platform: homeassistant
#    id: homeassistant_time

i2c:
   scl: GPIO5
   sda: GPIO4
#   frequency: 25kHz
   
bme680_bsec:
    address: 0x77
    state_save_interval: 1h
    iaq_mode: static


binary_sensor:
  - platform: status
    name: "light-and-air-quality"


sensor:

  - platform: adc
    pin: A0
    name: "Water Pressure"
    update_interval: 500ms
    unit_of_measurement: "psi"
    filters:
#      - multiply: 3.3
      - calibrate_linear:
        - 0.101 -> 0.0
        - 1 -> 232.0


#wifi

  - platform: wifi_signal
    name: "laq WiFi"
    update_interval: 30s
  
  - platform: bme680_bsec

    temperature:
      name: "Bosch Temperature"
      id: temperature
      force_update: true
#      sample_rate: ulp
    pressure:
      name: "Bosch Pressure"
#      sample_rate: ulp
    humidity:
      name: "Bosch Humidity"
#      sample_rate: lp
      id: humidity
      force_update: true
    iaq:
      name: "Bosch IAQ"
    co2_equivalent:
      name: "Bosch CO2 Equivalent"
    breath_voc_equivalent:
      name: "Bosch Breath VOC Equivalent"
    gas_resistance:
      name: "Bosch Gas Resistance"
#  - platform: bme680
#    temperature:
#      name: "BME680 Temperature"
#      id: "temperature"
#      oversampling: 16x
#    pressure:
#      name: "BME680 Pressure"
#    humidity:
#      name: "BME680 Humidity"
#      id: "humidity"
#    gas_resistance:
#      name: "BME680 Gas Resistance"
#    address: 0x77
#    update_interval: 5s
    
#  - platform: ccs811
#    eco2:
#      name: "CCS cO2"
#    tvoc:
#      name: "CCS voc"
#    address: 0x5A
#    baseline: 0x66BE
#    update_interval: 20s
#    temperature: temperature
#    humidity: humidity
  
  - platform: tsl2591
    name: "laq tls"
    address: 0x29
    id: laq_tls
    update_interval: 15s
    integration_time: 600ms
    gain: low
    visible:
      name: "laq visible light"
    infrared:
      name: "laq infrared light"
    full_spectrum:
      name: "laq full spectrum light"
    calculated_lux:
      id: i_lux
      name: "laq lux"
      accuracy_decimals: 0

  - platform: hx711
    name: "grow_res_level"
    dout_pin: GPIO14
    clk_pin: GPIO12
    gain: 64
    update_interval: 30s
    filters:
      - calibrate_linear:
        - -8800 -> 0
        - 46458 -> 10
        - 98943 -> 20
        - 156723 -> 30
        - 210661 -> 40
        - 237000 -> 50
      - quantile:
          window_size: 7
          send_every: 4
          send_first_at: 3
          quantile: .9
      - offset: -2.0
      - lambda: return x / 8.345;
    unit_of_measurement: gal
    accuracy_decimals: 3
    force_update: true


text_sensor:
  - platform: bme680_bsec
    iaq_accuracy:
      name: "BME680 IAQ Accuracy"
      
switch:
  - platform: restart
    name: laq restart



Thank you so much… at least I have something compiling now. That’s quite a sensor you created! What’s it for?

ETA: Still getting the same error with your code. Fudge

It’s for a grow tent. Double check your wiring, if it works with an old sketch, it would seem the pin assignments are wrong.