Hyperion component

Of course, I’ll share my code. Unfortunately I am on vacation at the moments so I’ll be able to post it next week or even a bit later.

I suggest you to search Hyperion forums, where I got all the information if you need it faster. You have to create another hyperion configuration file, which is driving Hue Bulbs. Then you can activate this configuration file with shell commands from HASS.

Thank you for your reply. From the information you provided I was able to track down a post on the Hyperion wiki which achieves this setup using 2 instances of Hyperion, each with separate config files, and forwarding the input from one instance to the other. I believe this is the process you were describing.

I’m going to get a couple of colour hue bulbs ordered (currently I use the white ambience bulbs in these fixtures) and give it a go!

Thanks again, have a good vacation.

Here’s the link to the hyperion article for any other interested parties - https://hyperion-project.org/wiki/Controlling-Multiple-Devices

Yes, Hyperion wiki has some information, but unfortunately not enough. I’ll try to write down all I remember.

  • First of all, you’ll have to become Philips Hue developer (or something like that) to get unique username (32 characters),
  • after that you’ll have to find out lightID for your Philips Hue Bulbs you want to control,
  • you’ll have to create a new hyperion configuration.

When it comes to configuration you have to set hue Bridge IP adress (make it static through Hue app or your router). The number of LEDs in number of your lights - so in your case 2 bulbs. You also have to set priorities so it does not interfere with primary Hyperion configuration. Also be careful with the frequency you will update Hue bulbs, because Bridge is not powerul enough to handle too many requests.

I know all I’ve written is allover the place, but it should help you a bit. I recommend you to check the following links:

Post on Hyperion site showing you how to control philips Hue devices:

I got the most important inormation to make it work from the forum. It’s in German, but Google Translate helped me so I could understand it perfectly, since I am not German. Here is the link:

I am also posting my Hyperion configuration (JSON) for Philis Hue, maybe it will help you, since I am driving two bulbs as well so it should look almost the same for you (apart from IP address and Username).

// Automatically generated configuration file for Hyperion ambilight daemon
// Notice: All values are explained with comments at our wiki: wiki.hyperion-project.org (config area) 
// Generated by: HyperCon (The Hyperion deamon configuration file builder)
// Created with HyperCon V1.03.1 (11.06.2016)

	"device" :
		"name"       : "MyHyperionConfigHue",
		"type"       : "philipshue",
		"output"     : "",
		"transitiontime" : 5,
		"colorOrder" : "rgb",
		"switchOffOnBlack" : false,
		"lightIds"   : [2,13]

	"color" :
		"channelAdjustment" :
				"id"   : "default",
				"leds" : "*",
				"pureRed" :
					"redChannel"		: 255,
					"greenChannel"		: 0,
					"blueChannel"		: 0
				"pureGreen" :
					"redChannel"		: 0,
					"greenChannel"		: 255,
					"blueChannel"		: 0
				"pureBlue" :
					"redChannel"		: 0,
					"greenChannel"		: 0,
					"blueChannel"		: 255
		"temperature" :
				"id"   : "default",
				"leds" : "*",
				"correctionValues" :
					"red" 	: 255,
					"green"	: 255,
					"blue" 	: 255
		"transform" :
				"id"   : "default",
				"leds" : "*",
				"hsl" :
					"saturationGain"	: 1.0000,
					"luminanceGain"		: 1.0000,
					"luminanceMinimum"		: 0.0000
				"red" :
					"threshold" 	: 0.0000,
					"gamma"     	: 2.5000
				"green" :
					"threshold" 	: 0.0000,
					"gamma"     	: 2.5000
				"blue" :
					"threshold" 	: 0.0000,
					"gamma"     	: 2.5000
		"smoothing" :
			"type"            : "none",
			"time_ms"         : 200,
			"updateFrequency" : 20.0000,
			"updateDelay"     : 0

	"framegrabber" : 
		"width" : 64,
		"height" : 64,
		"frequency_Hz" : 5.0,
		"priority" : 893

	"blackborderdetector" : 
		"enable" : true,
		"threshold" : 0.0,
		"unknownFrameCnt" : 600,
		"borderFrameCnt" : 50,
		"maxInconsistentCnt" : 10,
		"blurRemoveCnt" : 1,
		"mode" : "default"

	"xbmcVideoChecker" : 
		"xbmcAddress" : "",
		"xbmcTcpPort" : 9090,
		"grabVideo" : true,
		"grabPictures" : true,
		"grabAudio" : true,
		"grabMenu" : true,
		"grabPause" : true,
		"grabScreensaver" : true,
		"enable3DDetection" : false

	"bootsequence" : 
		"color" : [0,0,0],
		"effect" : "Rainbow swirl fast",
		"duration_ms" : 3000,
		"priority" : 701

	"jsonServer" : 
		"port" : 19446

	"protoServer" : 
		"port" : 19447

	"effects" : 
		"paths" : 


	"leds" : 
			"index" : 0,
			"hscan" : { "minimum" : 0.0000, "maximum" : 0.1000 },
			"vscan" : { "minimum" : 0.0000, "maximum" : 1.0000 }
			"index" : 1,
			"hscan" : { "minimum" : 0.9000, "maximum" : 1.0000 },
			"vscan" : { "minimum" : 0.0000, "maximum" : 1.0000 }

	"endOfJson" : "endOfJson"
1 Like

Thanks for all the info, it’s much appreciated - there’s certainly lots to go on there!

I’ll be trying this when my new Hue bulbs arrive soon :smile:

Hi guys,

asking for some help, I lost a full day on this and it seems that I can’t handle it.
I did a Hyperion system, but because of my Rpi2 on some movies I am loosing the image signal.
So in this cases I need to to shut down the Hyperion daemon. But for this I have to get a ssh or the jar… to much time.
So I said: OK, why not from Hass.
I have activated the Hyperion component, but it seems to light on the options, and it does not a shut down the daemon.

So, I have made a command line switch, to turn it on/off. But it is failing. No reason why. I have enabled debug, still a mystery why it fails.

ERROR (Thread-11) [homeassistant.components.switch.command_line] Command failed:...

The switch config is like this:

  command_on: /usr/bin/sshpass -p 'mypassword' ssh [email protected] '/storage/.config/autostart.sh'
  command_off: /usr/bin/sshpass -p 'mypassword' ssh [email protected] '/usr/bin/killall hyperiond'

Any ideea why I get the above issue.
(I know it is more of a switch issue, but I think that having the info in one place it is better and maybe the Hyperion fans are here)

Thank you

Hi @bogdan,

You mentioned HASS, are you using HASS.io or have you install homeassistant over raspian/another distro.

The reason I ask is because you will not have root access on hass.io which means you will not be able to restart the services unless you grant the homeassistant account root access (not recommended / or intended use)

I came away from bass.io

I forgot to mention it.
No, I am not using Hass.io. I got the same experience and I am on rasbian now. Latest Rasbian and homeassistant installed over it. And Hyperion is on LibreElec.


How did you guys get this working?

I’m running latest HASS.IO version and have the component installed… but how to use it now?
I don’t see anything in the log where it looks like it has not been installed / config looks good and is validated.
Additional to that I don’t see any entities as @Joeboyc2 does. How to get that?

I’m having trouble with the Hyperion component as well under the latest HASSIO.

I’v added the necessary bit to my config. However I do not see the component in the web interface of Hass.

Here is a snip-it from my configuration.yaml for the light section:


  - platform: hyperion
    name: Lil pi tv lights
    port: 19444    
    priority: 128
    default_color: [255, 255, 255]

#Wifi RGBW led stuff
  - platform: flux_led
   # automatic_add: True
        name: Bed head Light
        protocol: 'ledenet'
        mode: "rgbw"
# ESP tester greenary
  - platform: mqtt
    name: "Front Greenary Thing"
    state_topic: "esps/greenary1/light/status"
    command_topic: "esps/greenary1/light/switch"
    brightness_state_topic: "esps/greenary1/brightness/status"
    brightness_command_topic: "esps/greenary1/brightness/set"
    rgb_state_topic: "esps/greenary1/rgb/status"
    rgb_command_topic: "esps/greenary1/rgb/set"
    brightness_scale: 100
    optimistic: false............................

I have tried restarting Hass, reloading core files and even a reboot of the Pi running Hassio. However the component never load and there are no error messages to work off of.

If I purposeful misspell the component like " - platform: hyper--ion " I well receive an error from the “Configuration validation” this was just a test to make sure I was editing the correct file.

However I’m stumped why I do not see the component in the frontend web page and there are no errors being logged.

@Akriss I solved my issue yesterday; it is related to the fact that I had to have hyperion running on my other PI BEFORE I restarted HASS.

So Hyperion was on and running with USB grabber input; so fully working. Than I rebooted HASS and the component was added. Now I can use it.

Perhaps you should try that.

Ok I got it.
My troubles where two fold. (One) My pi with hyperion was on a segregated wifi sub net. (two) I had the wrong port configured.

Putting the pi w/ hyperion on a local (reachable from hass) sub net and fixing the port :roll_eyes: got it working.

Oh and of course having the hyperion pi on.
Thank you.

Does this require a separate pi to run Hyperion?

Currently I’m running HassOs on a pi3.

I’m still researching on a traditional setup using a separate device & hdmi grabber but seeing as I already own hue lights it would be cool to try this for now. Especially if I don’t need to purchase additional equipment.

If a separate instance of Hyperion needs to be added could a windows computer drive Hyperion to my HassOs?

I’m fairly newer to all of this so I’m just trying to see where my limitations exist. Thanks!

Finally installed Hyperion on my CoreElec Box and it works flawlessly.
Saw there is a component for it for HomeAssistant and gave it a shot and integrated it.

Hyperion light component become available, but the turn on turn off is not working. When I press to turn it off the light remains on, and the effects has no effect at all.

Can you guide me what could be wrong?

Are you using the latest version of hyperion? Hyperion NG?

if so it dosnt work with the component in HA, the component needs updating to support it.

I reverted to the old Hyperion for this reason

I’m using CoreElec+Kodi Leia v18 and Hyperion.NG v2.0.0
Tested it last night and it seems like it turns led OFF and it immediately turns back on.
Tried Priority 1, but it is the same issue.

Can it be a Hyperion option problem somewhere? Tried to stay on the default option as much as I could, but I could mistakenly tick something on what I shouldn’t

Could you clarify this? include references? ty

The hyperion component dosnt support the new ng release of hyperion.

It needs updating, I guess the commands are slightly different now, but I dont understand enough python in order to make amendments

1 Like

ah maybe thats why its not working for me, thank ill downgrade today

EDIT; worked right away after downgrade, too bad

The latest release of hyperion.ng now supports the remote, i worked with one of the devs to get it working, there where some missing commands that have now been added


So that means MAYBE we get HomeAssistant to work with Hyperion.NG finally? :smiley: