I am completely unable to update SkyConnect

I’m a bit unsure where to start, so I’ll try here.
The problem is SkyConnect which stopped working, I tried to find it in HA but to no avail, so far it has been working fine. I’m not specifically writing about any hardware or software configuration here.

My problem is that I cannot upgrade from the website: Home Assistant SkyConnect

I go to this address via Chrome, connect SkyConnect to the USB, press [Update Firmware], a window appears, select the SkyConnect v1.0 device and this is where the uphill journey begins.

I see the progress wheel start spinning - Connecting…, slow down a bit, stop for a moment, showing progress… and start spinning again - Connecting… then I get the message [Page Unresponsive].

I tried to update the firmware not only using Mac OS, I used two computers with Windows (older and newer) in both cases the same result, progress increased for a moment and then hung indefinitely.

It doesn’t look good. Has anyone had this happen? Is there any advice for this situation?

Only thing I can add is that there has been reports of the Webflasher being broke, but appears to have been recently fixed.