I am having lots of issues with devices disconnecting from my HA and think there maybe an issue with my conbee. Can anyone help?

Tags: #<Tag:0x00007fc4132a9c00> #<Tag:0x00007fc4132a9b10>

Hi, I am no expert with my HA configuration so please bear with me. With the help of a family member I have managed to put together a HA solution in my home which works for me and the many lights and switches and sensors I have. However it’s got to the point that I really cannot work out why the hell my devices keep disconnecting temporarily. I have about 40 odd zigbee devices comprising of IKEA Tradfri light bulbs and outlets as well as a number of aqara xiaomi buttons, switches and sensors. All these are connected to a conbee II and managed through the deconz app on my HA install. I have various automations in my config files that link switches/sensors to lights and various automations based on time of day (such as landing light at night). On a daily basis at the moment I will have a light not come on when a switch is pressed or a delay of 5 to 30 secs for that command to be registered. About 90% of the time everything is working but now, with the nights getting longer (I’m in the UK) the switches are being pressed more regularly, sensors being passed more often and a p**sed off wife because the kitchen light isn’t coming on as quickly as a regular wired switch would. I’m at the point of restoring all my original wall switches, putting in regular bulbs and getting off my fat arse to actually manually switch lights on etc.
I’m not 100% sure the conbee II is at fault. However at various points throughout the day everything connected to it will appear ‘unavailable’ for a few seconds or at times sometimes longer. This doesn’t happen to my two yeelight bulbs that I have. I have tried updating HA, deconz add on is latest version, my conbee II has the latest firmware. It is plugged into a usb extension of about a foot or two. I have moved the whole device away from potential interference. Checked config, many restarts! I don’t really know what else to do.
Does anyone else have better knowledge of the conbee II device and if this is a known fault and theres a fix, or is there any trouble shooting that someone can help with? Any input would be grately appreciated! Many thanks.

What version of firmware is your Conbee running? It is impossible to upgrade the firmware of your conbee stick when Deconz is running in a HASS.io container, even though there is a button “upgrade firmware” visible in Deconz, the button does nothing.
Try upgrading your firmware of your conbee stick to the latest version by shutting down your RPi, pulling out the Conbee, and plugging it in a windows, mac or linux machine, and do the firmware upgrade that way.
Your network will stay in tact, think of the conbee stick like a wifi stick, there is no config on the stick itself, it is just a hardware device that gives zigbee capabilities to your operating system. All the config is on the machine it is plugged into.

I used to have many issues, and first thought it was due to buggy integration. Turns out, I was running a 4 year old firmware on my stick that lagged lots of bugfixes.
Since upgrading a few months ago, not a single device on my network became unreachable, and the network stayed in tact through several reboot of the RPi, things that would have definitely caused issues with the old firmware

1 Like

Had no issues initially when I installed the conbee dongle but suddenly one day started to. I hadn’t exactly done any planning, simply installed it and away i went. Well when issues developed I fairly quickly understood that zigbee = wifi with very little power. They both use the same 2.4 GHz band, and the zigbee will be the looser. WiFi’s three non-overlapping channels (1, 6, and 11) use the exact same frequencies as ZigBee channels 11-22. So have a look what channels your 2.4GHz wifi is using and adjust to not overlap. Here is a link to a good overview of this issue and how to address it. https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html

Mine has been humming along perfectly ever since. I have 70 wifi devices and 30 zigbee.

Cheers

Hugh

Thanks @pjcarly. Thanks for your help. I had initially thought I’d updated the firmware. On the Gateway section of deConz there was an option to update the firmware and it appeared to do it and then the button disappeared and said it was up to date so assumed it was done. I have have followed your method this morning, after much wrestling with a spare windows laptop I have managed to download and update the firmware on the stick. Plugged back in restarted HA and deconz add on. However I am still having issues. I updated around 9.30am already had several drop offs.

Thanks @hughhallhh56. I have Google Wifi set up at home using two access points. I can’t change the channels on these. From my understanding they pick their own channels based on other wifi networks it detects in the area. From the info you provided I have changed my conbee II to channel 25 in the deconz advanced gateway settings. Hopefully this will help. I will keep you updated on the outcome.

I have tried both channel 25 and 11, each time having to resync my switches and sensors and I am still getting the same amount of drop offs. Any other ideas what could be causing this?

Hi folks - I’m having same issues as well with ZigBee devices becoming unavailable. After recent HA updates it seems to be getting worse as well.

As per guidance above I have changed the WiFi channels (Note if you are in UK and on TalkTalk internet you need to contact them as they need to activate this option on your router, as if you try and change it just reverts back to the original channel).

Well, after doing the change on the WiFi channel it hasn’t made any difference and still getting disconnects. I wonder if a ZigBee repeater will help? The house isn’t that big but a fairly new build and have had issues with RF (eOn tried to install a smart electricity meter but it wouldn’t work as to much interference due to the construction). Wifi signal is all okay in the house though…

I am using a Sonoff Zigbee sniffer, is that good enough? Should I try a Conbee II?

Any help appreciated.