I can't get Aqara D1 Wall Switch to pair with ZHA

I decided to consolidate my multiple Zigbee HUB’s setup to a single Sonoff USB stick using ZHA, and I ran into a problem.
Namely, my Aqara D1 Wall Switches don’t pair with my ZHA. Whenever I press and hold the D1 Wall Switch to initiate pairing, my Xiaomi Mi Gateway says something in Chinese but the D1 switch does not appear in ZHA.
All my other Aqara devices got migrated to ZHA with the same process flawlessly.

My D1 Wall switch is a Single Rocker with a Neutral wire, which should be the QBKG23LM model. According to this page Aqara D1 Wall Switch (With Neutral, Single Rocker) QBKG23LM Zigbee compatibility it should be supported by ZHA.

What am I doing wrong?
Any suggestions on how to troubleshoot this?

Pairing worked once I unplugged the Xiaomi Mi Gateway HUB
Looks like the D1 Wall Switches don’t want to leave their master, but are happy to find a new master once the old one is gone :slight_smile:

So basically we only need the hub for the first time to pair it with zha and then it’s okay not to use it ?

These switches have a problem (or at least a variant of them) where they have issues re-pairing once losing power. Mine is just a basic switch at this point because apparently one of the only ways to fix it is to connect them via UART to a computer and delete the memory.

Would personally avoid aqara switches if you’re gonna use them with home assistant zigbee adapter directly.