I can't get into my UI

I am unable to get into my Home Assistant UI. Normally I go through my DuckDNS URL, but suddenly this morning, I get “Unable to connect to Home Assistant.”.
I also can’t get the UI using the IP address:8123 or homeassistant.local:8123. (I never could after installing the DuckDNS add-on).
I even tried rebooting the host from the command console.
I know that Home Assistant is running because my automations are working.

Any help getting back into the UI would be appreciated. Is there a way to remove the DuckDNS add-on without the UI so that I can log on using the IP address again?

I turned off WiFi on my phone.
I try my duckdns URL and get a “This site can’t be reached” and the URL in the error message says "https://mydomain.duckdns.org/auth/authorize?"

Does this mean that my SSL certificate is bad?

HOWEVER- I CAN get into my UI using the Home Assistant App on my phone. I stopped the DuckDNS add-on and restarted Home Assistant. No difference. Maybe DuckDNA isn’t the problem?

From a post by @tom_i, I tried making my phone a hotspot and connecting my tablet to it. And, (Thank you Tom), I have no problem getting into my UI through my phone’s hotspot. (I.E. a different network).

More troubleshooting to follow…

If i got this right you can’t access home assistant from your local network but you can access it from any other different network?
If that is the case you probably messed something up with dns or route, or something similar on your router.

Thanks. I only have one “other” network and that is my phone’s WiFi tether.
I tried rebooting the router- no difference. In fact, I can’t even log onto my router from the wired ethernet or over WiFi.

I replaced the current router yesterday because the prior one (both owned by Verizon) would lose WAN three or four times a week. I could try plugging that back in.

It’s just strange. Here’s where I am at.

The old router made no difference, so I put the new one back online. I did, however, find a loose Ethernet cable.

Back on my local LAN. Three PC’s (one Windows, two Ubuntu) with ethernet connection to the router are able to log on to my UI through DuckDns.


Three tablets, will not. They are running Windows 10, Windows 11, and Ubuntu.
Connecting to the Home Assistant IP:8123, connects OK on all three.
Through DuckDns I get the Home Assistant logo and “Loading”, then “Unable to connect to Home Assistant”.

The tablet connections aren’t critical, but why can’t they connect to Home Assistant through DuckDNS??

Any insights would be appreciated.