I can't use ctrl-c / ctrl-v is ssh terminal - very frustrating

I hven’t fornd a way to log in to my raspi with HA. So I am dependent on using the built in web based terminal window.

The problem I’m debugging is /dev/ttyusb0 isn’t showing up for use with the sonoff zigbee 3.0 dongle. But that’s not my current problem.

To debug that, I find a commnd I can try on a forum post then I want to cut and paste that command and execute it.

$ ls -l /dev/ttyUSB*
$ lsusb
$ dmesg | grep tty

There is only ttyACM1 and ttyAMA10and both of those are owned by user: root, group: audio. I’m guessing it has something to do with a setting command.txt in the boot sector which might be a problem with conflict on the USB device.

So what the heck? Doesn’t everybody do this? How can we fix this problem?

Plus I can’t post what I’m seeing in the terminal windows.

On my laptop I currently use chrome, Version 126.0.6478.114 (Official Build) (64-bit).

I’m running ubuntu 22.04.

I’ll bet I’m not the only one who would like a definitive answer on this. Would appreciate some help, please.

Can’t confirm right now, but it should be Ctrl+Shift+C (or V) for linux according to this.

Do you mean like this?

Thanks for responding. The gotcha here is that I’m trying to use a terminal window provided as a module in HA. For starters, when I highlight some content in the terminal app, it immediately de-selects the highlight.

I use terminal, konsole, tabby in ubuntu and all seem to allow me to ctrl-c/v. Tabby’s is a little finicky.

Thanks, though.

That looks good. It seems a little obfuscated but doable. I don’t know how I missed that.

So on a usb thumb drive with a partition (smallish) named CONFIG, add a file named authorized_keys with no extension. Put my favorite public key on a single line in that file.

Put the usb drive in a usb socket of the HA raspi, reboot. Then I can ssh on port 22222.

" When the Home Assistant OS device is rebooted with this drive inserted, any existing SSH public keys will be removed and SSH access on port 22222 will be disabled."

It’s only removed when this USB is inserted with an empty CONFIG partition, right? We don’t need to leave the thumb drive plugged in every time we ssh into the HA OS?

BTW, I run commands like:
history | grep <part of some command>

all the time to cut an paste previous commands, modify, etc. I’d be glad to stay out of the OS if I could cut and paste in the web terminal. But without that, it was already frustrating me too much.

Thank you,

If you use the Advanced SSH & Web Terminal add-on, you can just ssh into that (on port 22) from any machine with an SSH client (even Windows can do it since W10) and don’t have to use the developer SSH interface (the one with port 22222).

The addon actually only gives you acces to the the “config” directory. It’s a plain docker container with that directory mounted and won’t help debugging OS issues.

1 Like