I did it. I defeated the horrible Google Home "cast-start" prompt sound!


#22

ah ok, thanks for the clarification.


#23

Has anyone managed to find a workaround for groups? I stumbled across this thread and am now a little disappointed to learn that it still doesn’t solve the beepBOOP when the Homes are used in Google Home app groups :frowning:


#24

yep, same issue here.
I was wondering whether bringing the volume down to zero before playing the silence file then back to previous volume would work, but not had the chance to try it yet. What do you think @hoffsta?


#25

Not really, as Google Home doesn’t seem to have the same idea of “zero” as humans do. :wink:

Means: Yes, you can set the volume to 0% before casting, but this doesn’t mute the device completely, just lowers the volume to about 5 to 10%. Maybe this is some sort of a “security” feature, because Google want’s to ensure, that users always get an audible response if something is happening with their device.


#26

@hoffsta WOW Thank You!! :smiley:
I finally got my Google Home Mini to announce the time on the hour every hour and I was looking for a solution to eliminate the initial chime before the announcement. I was figuring it had to do with the idle/off status of the device because it wouldn’t happen right after an announcement.
Your solution worked like a charm. It’s funny, when I started it I got the chime but that was the last time I heard it.
I think I am going to try @lolouk44 's idea of using a tts message with nothing but spaces to see if that works. Then if anyone else wants to use this solution you don’t even have to create a 1 second audio file.
Thanks Again So Much!!
RK


#27

I’m glad this solution worked out for some of you. I am just rebuilding my HASS install from scratch after moving from Rpi to NUC and wondering if there is now a better solution. I haven’t been following the forums at all!

@lolouk44 - does the blank TTS message others are attributing to you work well as a replacement for the silent mp3 file?


#28

Not sure why it’s attributed to me :smile:
I still use the silent mp3 file and it still works fine, but can’t see why the blank TTS message would not work


#29

I used a script to do the following:

  1. Lower volume to 1%

  2. Turn off GH

  3. Wait 1 second

  4. Turn on GH

  5. Wait 1 second

  6. Start playing my media (white noise)

  7. Set desired volume

Using this method, I don’t hear the “cast-start” or the “volume change” sounds

Here is my script:
https://pastebin.com/rpEt8CC6

It’s a modified version of this:
https://pastebin.com/PKEqSfZ5

The delays cause the media to take 4 seconds to start playing but I found if I don’t add those delays I would sometimes hear the sounds. I also found that I had to turn off GH (step 2) or else I would hear the sound if the GH wasn’t “off” when I started the script.