I don't understand "schema" from Zigbee2MQTT


I have migrated my Zigbee components from ZHA → Zigbee2MQTT. I also installed two (2) Aqara ZNCZ12LM. Some of the Zigbee components are associated with the Sonoff Zigbee 3.0 USB Dongle Plus coordinator.

In the attached diagram, you can see that 6 Zigbee devices are associated with one Aqara ZNCZ12LM. The other device of the same type “Socket: test plug Aqara 2” has no devices associated to it.

It is the same for the three (3) Sonoff S31ZB are interconnected but have no associated device.

I would like to understand this behavior? Is this normal? If not, what can I do to correct it.

Thank you for your help!

For Aqara, yes. They don’t entirely follow the zigbee standard.

Aqara non-routing end devices will pick an acceptable route (not necessarily the best route) when paired. They will then never change this route unless they are re-paired.

You can force a device to use a particular routing device (if you think it should have better reception) when pairing by using the drop-down box options other than “Permit join all”. Do this with the device in it’s final location, after you have added all the routing capable devices.

You can manually re-pair the device at any time, all other settings will be remembered.

Hello, I tried it a few times and the devices would not pair unless I chose the ALL mode. I was looking for a parameter that I had forgotten to initialize for a router.

Is it better to follow the following sequence:
1 - uninstall all devices including routers;
2 - install one by one the devices near their final location.

Thanks for the advice

Attached is the window of my routers. It is obvious that Zigbee2MQTT recognizes them.


Another question:

  • You say that during a manual repatriation “the other parameters will be memorized”. Does this prevent from changing the router?

Thank you

There’s no need to remove anything before trying the re-pair process with individual devices.

No it does not.

Are the Sonoff (router) compatible with the Aqara?

Not sure. I don’t have a Sonoff router.

Thanks, I tried several times to reassociate an “Aqara water leak” but without success with an Aqara router. I was 1m away from it.

I used to use ZHA (image). It still seems to be operational. Is it possible that it interferes in some operations with Zigbee2MQTT?

I will redo a test by setting it “disable”.


Even after setting “disable” ZHA, it doesn’t seem to change anything. I excluded a device “Aqara water leak” and tried to reassociate it to router “Aqara 1” but without success. When I told Zigbee2MQTT to proceed with an “ALL” association. The device associated very quickly with the “coordinator”.

I don’t understand