I give up, just is not worth the time and effort


#42

I have a feeling a lot of the bad experiences are SD cards filling up with history etc. rather than failing. They lock up and won’t boot then.


#43

Couldn’t agree with you more. I’m not a fan of using the Pi for anything needing reliability such as a security system. I too tried this and was constantly resetting and reloading. The never ending suggestions of new power supply and/or memory card was very tiresome. It’s great for experimentation but I didn’t enjoy any useful reliability.

I did come very close to throwing in the towel entirely on this thing until installing it on my NAS. Since then I have to say that Home Assistant has been extremely reliable ever since. I’ve only installed it once. I haven’t had a single reliability issue since going this route.

Good luck to you.


#44

The never ending suggestions that power supply is not the issue in most cases is very tiresome.


#45

Totally agree. When either or both of those are the problem 99% of the time what does @punkin suggest should be posted?


#46

Sorry, my intent was not to offend. Perhaps there is good cause to suspect the power supplies or memory cards but the frequency of this as a problem with the RPi just further encouraged me to move away from it. I have a small collection of the factory supplied power supplies and various memory cards that came about from my journey with this. I completely agree that others may be having better, similar or worse experiences but for me I just gave up on it and landed on something that was considerably more satisfying. It’s unfortunate that the RPi couldn’t be made to work as it would have been a far less costly.

Again, didn’t mean to start a fire here. Just sharing my experience and that once I made the jump to use docker on a more predictable platform, I’ve had good success and did keep further interested in Home Assistant and did prevent me from completely abandoning this project.


#47

Did you buy a canakit for your raspi? Or did you piecemeal it with your own parts?


#48

In all three cases I bought complete kits. The last kit I purchased was version 3. All parts/materials came in the kit from the manufacturer.


#49

From canakit? Canakit doesn’t make the raspi, just the cases and they buy a power supply & heat sink. Everything is designed for the raspi though. If you purchase their kit, everything should work swimmingly. HA will struggle on any pi but a pi3 though. Even then, it sometimes struggles on a pi3.


#50

That’s why i never recommend PI’s to be used with critical system unless you can run a read-only file system - otherwise it’s good for a week or two to test the software you want to run then install everything on something better - a nuc, a brix, etc… My longest running pi with home assistant has 2 years uptime so far and still going strong but I won’t be deploying another one unless it’s a temporary project… just too much time wasted making the pi work well enough…


#51

I run HA on RPi on USB Flash Drive (without SD Card, boot from USB) and it run flawlessly, no problem occured.
Last year, when I use SDcard, even without HA, my SD card is corrupted and several damaged/cannot be used anymore.


#52

Try to bulletproof your setup. Mine RPi is working for a year right now, all on first set of hardware.
Quality USB charger (I have multiport Anker one, RPi is put into drawer), next is quality SD Card.
Smaller is better, try to keep SLC and MLC cells, they have a better longevity.
Next, try to keep system to write as low as possible. I have cloud-based free ELK stack and local rsyslog is forwarding logs here, without storing them locally.
Next is Home Assistant itself. It was keeping logs, now emits them to local syslog. Also, there is a local SQLite database. I’m thinking about moving it away to a home NAS storage.

If you will be able to mount SD-Card read-only, then you will stop messing your cards and whole system will have a better millage.


#53

And a fantastic bloody FREE software it is!


#54

I’m running Hassio for a really long time on a 3B+ with a decent SD card and not even a original power supply. Never had any problems with my raspberry, my SD card or my psu.
It’s your config. Period. Don’t blame hassio for this, you simply can’t.
Start by checking what is causing the high IO.
You can also save time by simply moving the recorder db to you NAS (if you have one).
You can connect your hassio instance to a mariadb on a (Synology) NAS within 10 minutes. Its super easy. With this done you move a LOT of IO from SD card to your NAS and i expect you to have a stable hassio.


#55

With the last hass.io image for raspberry. Is still not supported to use a SSD?
It was the blocking point for me to migrate on Hass OS.


#56

I personally would advice a NUC, NAS or even better a server to put HA on. But that is just my personal preference though.


#57

I have also had problems with SD cards on my KODI running on a PI, changed to USB and it has never crashed.

I read in this thread that people are running a Hassio on a PI with HDD.

How do you officially get a PI V2 or V3 to start from SD but run on HDD or USB.

There should be a official guide if it can be done.

Regards, Dave


#58

Currently HassOS cannot boot from USB, to make Hass.io boot from USB you need to install Raspbian to boot from USB then install dependencies and docker-ce and then install Hass.io like explained here in “alternative” section:


#59

Hi, thanks for the reply but I cant see how that link helps,

I understand that all but the latest PI cant boot from USB, but surely the OS can be on SD (as it should be read only) and the config / database files could be pointed to the USB drive as that is read write.

I don’t understand after all this time that this SD / USB config is not an easy option when installing.

Re Dave


#60

Moving my db off of hassio made a big difference for me.


#61

The point of a raspberry is to have something small, low power and cheap.

If you are going to put your data from home assistant on a bigger gruntier computer, why not put all of home assistant on the bigger gruntier computer.