I have changed ip of my nas when hassio was installed and now can't access it


I have archlinux and docker with hassio on my diy nas and due to router upgrade, I have changed IP address of my nas from to
I have just thought that I can simply use to access again my HA but it is not a case. It is working as see it on docker stats but I can get to the web interface.
In my configuration.yalm I do not have an old IP address as trusted or so?

I tried to google out this problem as I believe not the first on but without success.
Help, please.

You should be able to identify it in your router’s administration tools, and get the new IP from there.

Or in Linux, run ifconfig.


I don’t think this is going to work as they are not in the same range: 192.168.0.x vs 192.168.1.x unless your network has changed entirely to this range I don’t think you will be able to connect just like that. You can however try to manually change your computers ip to be in the same range and access it from there. though this will mean your own computer is no longer accessible for devices living on the 192.168.0 range.

Edit: it seems you could also do it with a subnet change as described by some people here:

network testing usually starts with ping.

On the machine with the web browser, can you ping the home assistant machine?

Yes I can ping and even more I can ssh so I can run command like docker stats etc. What kind of setting in HA should I change as I can access configuration file etc.

You can’t reach your container port any more because your container’s application is actually bound to host IP address upon start up so when the IP gets changed it’s not going to work until you restart your application. Then it should start to work again.

I rebooted NAS a few time with new network setting and somehow HA still do not pick up new nas ip adress. So what in the HA setting I should change to make it accessible again. I can see on docker stats that hassio HA and addon are working ( I can access Phoscan which mean deconz is working) but I can access HA web site.

HA doesn’t have such a setting.

Unless base_url is influencing it? https://www.home-assistant.io/integrations/http/#base_url

That’s unlikely. I have base_url set to my domain name, but I access it via IP address all the time.

Then once again I urge you to dig deeper into the docker side of things.

post the output of: docker container ls

and: iptables --list

It may well highlight the issue for you.

OK I made it via ssh, edited configuration.yalm and changed all wrong ip in smart devices to proper new ones. removed home-assistand db v2 and core-config.entries, rebooted whole nas and I can get to web interface and all is working.

1 Like