I keep failing while trying to flash my first espHome device

See screenshots at Imgur: The magic of the Internet


I really hope you can help me to flash espHome on my first device. It is an esp-01 s. I tried flashing it with the ESP-Flasher tool that I baught on the same site as the chip itself. When trying to flash it in the Home Assistant interface it gives me an error and that I should hold the BOOT button, but neither the flasher nor the esp-01 have any buttons.

Then I tried flashing it with the windows flasher tool, but there I got the error that there might me “serial noise”. I do not know what to do about that.

I may have a USB to TTL FT32RL flasher (the ones where you have to set it up via a breadboard) laying around. Do you think it could work better that way or am I doing something else wrong?

Sidenote: The blue LED on the ESP-Chip is lighting up when I plug the flasher in the USB-Port.

Flash enable (the “boot button”) is GPIO0, you need to short it to ground to enable flashing.

Here’s a video that explains it.