I like pip install BUT it may not have worked

On windows 10 home.
Python 3.6.3
running in virtual environment I pip’d home-assistant per:

C:\...\> pip3 install homeassistant
C:\...\> py -m homeassistant --open-ui

During start up there were a few assertion fails. All I get is an inert web page with glyph and title.
(Sorry, no image as I am new user so treated as low life and cannot add more than one image).

On first run console got to a Timer.Start message. Subsequently, it does not get any further now than displayed below.

hassL-01

I did try also ripping out AppDate/Roaming/.homeassistant and restarting. Gets to same point.

It is otherwise first fresh install of home-assistant on windows.

Any help appreciated.

I will be trying on my RPI later today in any event, I am using the windows box for ease and famil.

Cheers,
B

You didn’t show all your steps, so I just gave it a try myself, following these instructions. Here is exactly what I did on Windows 10:

- Install Python 3.7.3 for Windows
> py -m venv homeassistant
> cd homeassistant
> Scripts\activate
> py -m pip install --upgrade pip
> py -m pip install wheel
> py -m pip install homeassistant
> hass

Worked like a champ!

EDIT: As a bonus, you can also add this step (after installing homeassistant):

pip install colorlog

Ripped out home assistant, including AppData/Roaming/.homeassistant

Followed the “proper” instructions thank you. I take your point, very important to follow the proper installation instructions.

Got the following error.

hassL-02

Same behaviour in the end. Inert web page with glyph and title.

The only difference between my original install approach and the “proper” one was absence if install of wheel on initial failed install&run attempt and presence of install of wheel in this “proper” install&run attempt.

So, the upshot, the problem exhibited is not a side effect of the absence of wheel install in initial attempt as wheel install did not fix problem in second approach. Problem is exactly the same with or without install of wheel.

Problem is the same whether you start with hass or hass --open-ui.

I will take it there is a problem with the current version and windows, so I will build my RPI instead.

Cheers,
B

It may be that somehow the basic install of Python itself was accidentally changed in a way that it’s causing the problems. E.g., if you tried to install without a venv, or without activating it, that might have changed things. I literally did the exact steps I showed and it worked fine.

My honest advice would be not to use Windows at all and if you do use docker instead of python. It will save you a lot of trouble.

Yep, dumped windows and loaded HypriotOS onto a RPI3B+ and everything is now smooth.

1 Like