I messed up the Lets Encrypt install. How to start over?

I tried to do the Lets encrypt install but I got shut down because I forgot I had Pihole running a web server on port 80. I received this message:

Port 80 is already in use by another process. This will prevent us from binding
to that port. Please stop the process that is populating the port in question
and try again.
Press Enter to Continue

I changed the pihole port and restarted lighttpd then pressed enter and got this:

Cleaning up challenges
At least one of the required ports is already taken.

 - If you lose your account credentials, you can recover through
   e-mails sent to [email protected].
 - Your account credentials have been saved in your Certbot
   configuration directory at /etc/letsencrypt. You should make a
   secure backup of this folder now. This configuration directory will
   also contain certificates and private keys obtained by Certbot so
   making regular backups of this folder is ideal.

I didn’t get any folders like /etc/letsencrypt/live as I was expecting. I tried to run the command again and received this:

  certbot-auto [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] ...

Certbot can obtain and install HTTPS/TLS/SSL certificates.  By default,
it will attempt to use a webserver both for obtaining and installing the
certbot: error: unrecognized arguments: http-01 [email protected] hass-example.duckdns.org

I tried renaming the /certbot and /etc/letsencrypt folders and starting from scratch but received the same result as before. How can I completely clear all this out and start fresh? Thanks!

Can you paste a (sanitized) version of the exact command you’re issuing?

Just like this from the HA Guide, but with my email and domain name:

$ mkdir certbot
$ cd certbot/
$ wget https://dl.eff.org/certbot-auto
$ chmod a+x certbot-auto
$ ./certbot-auto certonly --standalone \
                          --standalone-supported-challenges http-01 \
                          --email [email protected] \
                          -d hass-example.duckdns.org

If I remember correctly, if you just run ./certbot-auto certonly it should take you into a guide that lets you input each required piece of information individually.


This seems like a good post. I haven’t used it personally but it appears accurate. Might help you find any issues.

This did the trick. Not sure why running it with the standalone arguments was failing but now I don’t care. Cheers!

1 Like

Thank you. Still applicable in 2018!