I need help adding a TP Link device that is on another subnet


I have a layer 3 site to site vpn between my apartment’s and my parent’s apartment’s. So basically, my apartment’s is on the subnet ( and my parent’s apartment’s is on the subnet ( Discovery only works for devices on my subnet. I want to add a smart bulb ks125 that is on their subnet. How do I add a device based on it’s IP? I looked at the documentation and I couldn’t find anything. I found this tread that mentions modifying configuration.yaml, but there is nothing about tplink in my configuration.yaml. I tried adding the code that is suggested in the thread, but it didn’t change anything. Can someone help me understand how I can add a TP Link device based on it’s IP address? I suppose it’s possible, because that thread said it was. If not is there another way to add it?

Thank you

This sounds like it could be an mDNS thing. Can your HA instance or other apps resolve hostnames for devices across the different networks, or is it only the tp-link devices that are an issue?

mDNS does not work, because multicast is not routed.
You will have to find it manually.
Add the TPLink Kasa integration and put in the IP address of the device.

Yes, that’s exactly what I’m asking. How do I add a device in the Kasa integration via IP? In the integration’s GUI, it never asks for IP. The thread that I linked said that I needed to add some lines of code in the configuration.yaml, but I’m not sure what to add.

Regarding mDNS, it doesn’t work between the two networks. I was hoping that I could just use the Kasa integration with the IP address of the device that way, I can just ignore discovery, but if there is a way to get discovery to work on multiple networks than that would be good as well. Any solution is good as long as I can manage to add the device to HA.

If I add the TPLink Kasa integration in GUI, then the first thing I need to input is the host, which is the IP address.

have you tried this to have access to both networks and add the lights

Oh my apologizes. I tried adding the IP in the host field, but it gave me connection failed so I assumed it wasn’t asking for the IP. I can ping the bulb (network B) from HA (network A) without any issues. I also have a couple of cameras (network B) that work just fine in HA so I guess something else causes the connection problem between the Kasa Integration and the Bulb.

You mean assigning two addresses to HA, one on network A and another one on network B (where the bulb is)? I didn’t, but I’m not sure if I can or at least it’s not that straight forward, because the two networks are behind 2 different routers (router A for network A and router B for network B). Devices from A can communicate with devices from B because there is tunnel between the two routers, but I don’t think I can add a device on network B if the device is behind router A (at least not without some changes to the settings).

I think the Kasa smart device is using port 9000, so that needs to be open for traffic.

Ok, so I had given up on it, but today I was tinkering with some other stuff inside HA and I decided to try to add it again and it worked without any issues using the GUI. I just specified the host (IP address) and this time it worked. Idk why it worked now and it didn’t before, but it did so that’s good.

Thank you all for your help.