I need help with Home Assistant Container configuration for Matter devices

( I intended to make a container-only setup. By now I got aware, that Google’s Open Thread Border router container is not intended for deployments. Furthermore, the Home Assistant team did not yet release a container besides the Addon available. This is why I used Container and VM mixed for now. Please don’t make recommendations on my setup )

So, my setup is as follows. I have a single mini PC running with:

Docker containers (running with podman):

  • Pihole (DHCPv4 and v6 enabled in Web UI)
  • Home Assistant
  • Matter Server


  • HAOS (running Open Thread border router Addon) and assigned my Dongle to it and configured it like it was working when I had running HAOS baremetal.

I connected HA Container with Matter server and the OTBR Addon from the VM sucessfully.

I bridged my ethernet device with br0 to access home assistant from other clients in my local network.

When I try to setup Matter devices, I get the message “network connection could not be established”. Checking the Matter logs, does not show me any connection attempts.

I already tried disabling pihole and enabling my routers dhcp again, but this did not fix anything. I then moved on, using only the VM and connecting everything again inside of it.

Don’t know what I should do next…

Currently, our compagnion apps use the Android/iOS SDK to do commissioning. The way commissioning works there is that they do a full commissioning to an intermediate Matter fabric, and then do a Matter sharing with Home Assistant (if you are interested, a bit more in depth explanation is in The State of Matter stream we had last year)

The fact that there is nothing in the logs on the Matter Server container tells me that the first commissioning flow doesn’t complete. So there is likely some connectivity issue between your VM and your phone.

Are they on the same physical network (broadcast domain)? What device are you trying to commission?

I try to commission my Eve Motion device (and reset it before I scan the QR code).
At least I think, that every device is in the same network. I can ping from PC to mini server within ipv6 and back. Also my phone has bluetooth enabled, has a wlan connection and has the same subnet

I already tried simplifying the network by enabling DHCP on the router and disabling the pihole’s dhcp again. Also I tried using only the vm’s HAOS with additionally set up matter server, otbr (configured conbee3 stick).

Currently I still don’t get it working…

I guess it is something specific to debian bookworm. I can’t explain why it doesn’t work…