I will pay you $50 to get this working.(Smartthings Bridge)

So up until version 60 or so I had a fully configured Home Assistant set up working great, etc.
I just don’t have the time to work on it at the moment and would love some help.

Here is my set up.

Pi #1 - Home Assistant running in a virtual environment with Mosquito MQTT Broker
Pi #2 - Pi-Hole
Pi #3 - Smartthings MQTT bridge - This is where the issue is coming from

I am having a lot of trouble getting Smartthings MQTT Bridge installed and talking to the broker. I will pay you $50 if you are able to get this working.

I will give you remote access to make everything easier. For reference here is my previous configuration.
The important parts are the locks and a couple of random switches.


what appears to be the issue?
Also you may want to review what you’ve shared on github. You really should use secrets to store zone coordinates

oh and keep your money, we help for free over here, the way you pay back is by helping others when you’ll get some time :slight_smile:


Alright, so I went back to HASS.IO and was able to make some progress. Though I still can not seem to get it to work.

I have the bridge and MQTT talking, but nothing is being updated. I’ve checked the MAC address, etc.

Smartthings Config

  "broker_host": "localhost",
  "broker_port": 1883,
  "preface": "smartthings",
  "state_suffix": "state",
  "command_suffix": "cmd",
  "login": "pi",
  "password": "NotARealPassword",
  "bridge_port": 2080

MQTT Config

  "plain": true,
  "ssl": false,
  "anonymous": true,
  "logins": [
      "username": "pi",
      "password": "NotARealPassword"
  "customize": {
    "active": false,
    "folder": "mosquitto"
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"

I receive this data from Smartthings/Broker

info: Incoming message from MQTT: smartthings/Nanoleaf/switch = on
info: Skipping duplicate message from: smartthings/Nanoleaf/switch = on
info: Incoming message from MQTT: smartthings/Backdoor Lock/lock = locked
info: Skipping duplicate message from: smartthings/Backdoor Lock/lock = locked
info: Incoming message from MQTT: smartthings/Frontdoor Lock/lock = locked
info: Skipping duplicate message from: smartthings/Frontdoor Lock/lock = locked
info: Saving current state

Did you activate MQTT discovery in homeassistant?

# Example configuration.yaml entry
  discovery: true
  discovery_prefix: smartthings


  broker: localhost
  port: 1883
  client_id: hass
  username: pi
  password: !secret http_password
  protocol: 3.1
  discovery: true
  discovery_prefix: smartthing

Nothing shows up in the <> menu regarding your sensors?

I’m not sure, but I don’t think the missing s at the end is significant.

good catch

Fixed the typo, still no luck. Nothing is showing in the <> menu.
Maybe it is the MAC Adress. Should it be the docker image address or the physical address?

The SmartThings MQTT Bridge doesn’t use Discovery unfortunately. You have to create the Sensors, Binary Sensors, etc. by hand. Discovery is filed as an issue.

An example of my Multi Sensor for the Open/Close section.

  - platform: mqtt
    name: "Bedroom Door"
    state_topic: "smartthings/Bedroom Door/contact"
    device_class: door
    payload_on: "open"
    payload_off: "closed"
    payload_available: "ONLINE"
    payload_not_available: "OFFLINE"
    retain: true
    qos: 1

It’s super out of date since I’ve moved and revamped my whole setup but this has examples of a lot of the ST to MQTT devices. https://github.com/techwithjake/home-assistant-config

I don’t use HASSio so I’m not sure how much different it is from the Python ENV version but this should get you going in the right direction.

Another thing I’ve found is that if you have your Pi hooked up to WiFi and Ethernet, make a MQTT Device and SmartApp on ST’s end for both the WiFi and Ethernet IPs and MACs. Mine is working flawlessly now. And as @lolouk44 said, keep your money. We’re here to help one another. Pay it forward if this helps.

Alright, so Smartthings is properly talking to the broker now, as when I unlock a door it updates properly on Home Assistant. It doesn’t seem to be working the other way around.

I had exactly the same issue, I decided in the end to just buy a USB Zigbee device (I think if you are in the US you can get a HUSBZB-1 ).

No more issues then!

I’ve been tempted to just get a USB stick, but I have been using Smartthings for a couple of years and havn’t had any problems.

Here is my device settings. I’ve tried every combonation of MAC address I can. :expressionless:

I had the same issue with the bridge and my smart lock, updates from HA wouldn’t be set on ST. What fixed it was modifying the ST bridge config.yml and uncommenting the

# state_read_suffix: state
# state_write_suffix: set_state
# command_suffix: cmd

lines. My HASS configuration.yaml for the lock:

  - platform: mqtt
    name: "Front Door Lock"
    command_topic: "smartthings/Front Door/lock/cmd"
    state_topic: "smartthings/Front Door/lock/state"
    optimistic: false
    payload_lock: locked
    payload_unlock: unlocked
    retain: false
    qos: 1

Note that this means you have to update all your devices in the configuration.yaml file. If you have sensors, they only have a state, so state topic would be "smartthings/sensor1/state". If you have things like switches, you would need to do the same, but with a command topic "smartthings/switch1/cmd" for actually turning the switches on and off and also a state topic to read status.

Hope this helps. I’ve had everything working great so far. Will eventually just get a z-wave/zigbee dongle and migrate to fully local but for now I’m using ST.

Also to simplify issues with connectivity, I have the MQTT broker running on a docker container in bridge mode (virtual switch) with it’s own local IP, and the ST bridge also running in bridge mode with its own local IP

Just an FYI. I was seeing this same behavior. What ended up fixing it was going into the ST App on your phone, selecting the device, then clicking on the gear. This brings up the properties pane. Click on ‘Set Date Format’ and select US (UK might do the same thing), as by default nothing is checked. As soon as I did this the data started flowing into HA immediately.

Maybe that helps someone…Cheers!!

Use IP and Mac address of the physical device and not of the docker.
I was also fiddling with it for weeks. In my case it was something else though but I had some problems with the IP and mac too.