iBeacon distance always "Unknown" but SNR updating?

I’ve recently picked up a couple Feasycom FSC-BP108 iBeacon fobs from the list of recommended working ones at iBeacon Tracker - Home Assistant to try and monitor if my trash cans are in or out.

I’m using one of the recommended Bluetooth USB adapters from Bluetooth - Home Assistant the model Kinivo BTD-400

I followed the directions that came with the fobs to remove the default/demo advertisements and add a custom one and name my fobs “trashcan” and “recycle”. They show in Home Assistant iBeacon integration with the names.

Problem is they seem to show with “Unknown” distance all the time in Home Assistant, although I can see the SNR updating consistently.


Oddly some thermometers we have do show distance under the iBeacon addon, so I think that means it’s a config issue…but I have no idea why the iBeacon fobs don’t show but the thermometers do.

Anyone have ideas?

UPDATE: I may have figured it out. The guide said to put power as “0” for default, but I think I need to specify some number less than 0…putting at -65 seemed like it made the distances work semi-reasonable readings. Not sure I understand how to tell the proper value but now it’s reading something at least.

I’m having a somewhat similar issue. For me, my Power is being reported as 100 dBm, the signal strength of the device varies a bunch (from about -50 to -90) as I move it around. For me, the distance is always zero.

You mentioned being able to set the power to a value, but I do not see that in my interface. Also, I’m not about to find the documentation you were referencing regarding setting the power default.

Any pointers? Thanks!

Are you using Feasycom beacons? The power was a setting in the Android app for setting them up. I can attempt to get a screenshot later if you want.

To clarify a bit, there might be some misunderstandings with the wording here.

"Power" refers to the broadcast signal power of the beacon. Sorta like the volume button on your car stereo. Default for most beacons is 0, as in 0dBm. Use the Feasy app to set this back to 0 if you changed it to something else. Increase it to +4 if you want a longer range for the beacon. Lower below 0 if you want a shorter range.

The key words you are missing are “Calibrated RSSI”. Maybe Feasy calls it something different. They might call it something like “RSSI at 1 meter”.

Anyways, this is a set figure that the factory usually inputs, and you never need to change. This number is used in the distance calculation by the HA. So if you set this to 0, everything would be messed up.

For Blue Charm Beacons, our standard “Calibrated RSSI” is -59. What this means is that when you hold our beacon 1 meter away from the scanner, you can expect the live RSSI reading on the scanner to be -59.

Since I don’t know which beacon you are using or what Feasy beacon calibrated levels are, you can just use -59.

No, “Power” in HA iBeacon device entity matches the value set in “RSSI at 1 meter” value is in the Feasycom app.

The beacons send out a fixed power level, then it seems the iBeacon Tracker compares the actually-heard power level to the announced calibration power to compute distance.


Oh you’re right! I can clearly see that in your screenshot of the HA card.

Not very correct BLE terminology though. Someone should change this to “Calibrated Signal Strength” to make this more obvious.

1 Like

Yeah I’m not familiar with the terminology either, but it confused me for quite a long time before I worked out that was just a reference value.

I can imagine moving the beacon closer and farther and being completely frustrated that the “Power” number is not changing! :laughing:

Just to add some sad/funny content to this topic: Eddystone calibrated RSSIs are not calibrated at 1m like iBeacons, but instead are calibrated at 0 meters. :weary: