iCloud Integration - Keeps popping up Apple ID Sign in request on iOS devices

Hi there,

Firstly, thanks in advance for taking the time to read this. I did a search but couldn’t find the exact problem I’m experiencing.

I’m running the latest version of Hassio in a virtual machine, and up to now I’ve not really had many problems. Up until a couple of days ago, iCloud integration worked perfectly.

Now, after a routine reboot (without any update or change of anything) I’m suddenly getting pop ups every couple of minutes on my iPhone and iPad informing me that a new sign in is being requested, the source seems to be Home Assistant.

I verified this by turning off my HA server, and the 2FA authentication popups stop completely, until I turn HA server back on. We are then in a continual loop of requests.

I tried deleting the iCloud integration via the GUI, then rebooting and re-enabling and going back through the authentication process (via GUI), but the problem still occurs.

I wondered if by deleting the Integration I was properly deleting all the config, or if I need to do something manually to get a completely fresh install. I’m essentially trying to establish a way of eradicating any left over config/files that might be causing this problem.

Hope that makes sense, I’m completely out of ideas as to how to rectify this.

Thanks for reading, and thanks to those involved in making this stuff.


I can’t help you much, but I can confirm that I had the same issue that started about 3 - 4 weeks ago. I also narrowed it down to the icloud integration on home assistant.

Unfortunately, deleting the integration, making sure I had nothing left in the configuration.yaml, rebooting and resetting up from scratch solved it for me. I have not see it since I did that.

But yes, I can confirm I saw the same issue as you.

1 Like

Thanks for the response, appreciated.

Yes that’s the first thing I thought to try too, I removed the integration and checked the config yaml too.

Strange, I’ll try it again in the hope that’ll sort it. If not I guess I’ll just have to remove the integration permanently as I can’t live with that pop up on my phone every few minutes.

Thanks again

I had this exact issue about 3 weeks ago. I deleted the integration after the debug logs said nothing about authentication. Readding it solved it.

I’ve been having the same issue with HA 0.115.6. It just came up one day.
On my ‘master’ iPhone I keep getting the Sign-in request notifications from Apple. But when I clicked Allow it would present me with the 2MFA code which I could not enter anywhere.

So I deleted the integration from HA, did a restart and added the integration again and all seems to be working fine again.

1 Like

It seems to do this every few months to me. Same resolution as others: Remove the iCloud integration, restart HA and re-add it.

As this work-around is working, today I received again the Sign in requests on my phone from HA. This was not happening before as frequent as it does now.
Yesterday I re-added the HomeKIT integration and I assume this is the reason why I keep getting the Apple sign-in request on my master iPhone again.
But I hope this issue is not staying because removing/adding the iCloud/Apple integration on a daily basis just consumes to much of my time :slight_smile:

1 Like

Having the same issue, deleting iCloud and reinstalling fixed this issue. I believe it is something with 2FA of Apple, it would be nice if we could refresh the token without having to delete and reinstall.

I agree.
as the work-around works it seems to be only for some limited period of time. Yesterday I deleted the iCloud integration and added and configured it again. But today I’m receiving Sign-in requests again on my iPhone.
So the work-around is not really a permanent solution.
I have created a new Issue on github.

1 Like

Are we talking about the same integration here? I see the topic relates to icloud integration, you mention icloud - but the git issue is regarding the homekit integration. Are they one and the same or does one still need raising for the icloud integration?

As the document stated, this have to be done every couple of months. But thats not the issue, the issue is sometime it will need to validate more often, multiple times a day even when rebooting the machine that contains HA. This happen if Validate from a trusted IOS device when first a notification pop up and click allow will give a code, this code can not be enter as HA give no option but to force request another code via SMS, another code is send thro SMS which HA will accept, at this point it will start to ask for validation randomly.

Here what is did to stop it.

  1. detete the icloud integration
  2. delete the icloud folder in the .storage folder if exist
  3. Reboot the machine, not just restarting HA but reboot the whole system that contains HA
  4. Enter HA from a device that is NOT trusted IOS device and add the icloud account into the icloud integration. (at this point you will get the notification pop up on the trusted IOS device, DONT click allow dont click anything). continue choosing phone number on HA and continue setup, you will recieve sms code, enter that code. when HA accept. the pop up will dispear and thats it.

HA need to have first option to enter the first “allow” code

1 Like

No. Still dose it

1 Like

Sadly after 5 hours popping again

1 Like

Oki not working, mine also started again. I am disabling for now. hope there a fix. Anyone know a fix please let us know

1 Like

Hey all,
I tried the proposed workaround but it did not last long.
After roughly 5 hours the popups appear again.
If I could enter the code to re-acquire a token that would be fine for me :slight_smile:
Best regards,

1 Like

Yep. Same. Workaround lasts a few hours.

1 Like

Anyone found a solution to this? I am seeing the same issue and ended up remove the iCloud integration for now.

I’m the same, tried removing the re-adding… no joy. Then tried removing, restarting and then re-adding… no joy. Removed for now as it was popping up on all devices. Seemed to come up twice each time and didn’t matter whether allow or don’t allow was clicked.

I have the same issue, I’ve tried the remove reboot reinstall recommendation and it brings what seems like mere minutes of relief.

I am having the same issue, try to delete everything and setup again. the popup return after few hours.

1 Like