I'd like to understand errors and warnings in my log

Hi folks!

Spending my cold nights in the man cave tidying up the house. Erm… the house - brain.

I keep seeing items in my home-assistant.log that frankly I’d like to eradicate. I really only want to see things in here I should action, not learn to ignore. LET THE SYSTEM DO THE PARSING I say. Not me, I’m too old for this :slight_smile:

Case in point:

2018-06-26 20:33:56 WARNING (Thread-19) [pywemo.ssdp] Error fetching description at
2018-06-26 20:34:15 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting
2018-06-26 20:34:15 WARNING (MainThread) [homeassistant.core] Unable to remove unknown listener <function async_track_point_in_utc_time.<locals>.point_in_time_listener at 0x6cd05300>
2018-06-26 20:34:18 WARNING (Thread-16) [netdisco.ssdp] Found malformed XML at 
invalid request
2018-06-26 20:34:18 WARNING (Thread-16) [netdisco.ssdp] Error fetching description at

I see the pywemo and netdisco :notes: all the time in here. I read through the community and saw a few others ask about these - but no one really nailed it. I saw that the discovery component was given the ability to “ignore” stuff - but seemingly adding the ignore belkin-wemo had no effect. At least no effect when I tried it…

I get that this is discovery reaching out and trying to find advertised services. Maybe it should have a “try threshold” and stop hitting its head on the wall?

Please - tell me I’m wrong and show me how to put this poor thing out of our mutual (1st world) misery :slight_smile:

Thanks folks!


Have you looked at your router and found out what those IP’s are? That’s where I would start. See what the IP address is, figure out the component it is trying to discover. Then turn the discovery off or fix the issue.

EDIT: YOu have 2 IP’s you should be looking for:

I think these come from the discovery component finding something on the network and expecting to get a response from the device. That may not be how the device responds to the network which prompts the error. You might want to try asking this on the developer Discord channel.

Should clarify. I don’t think this is an error per se, but rather “I was expecting this but it wasn’t available” Again, the developers would be the definitive answer.

Yes thats exactly what’s happening. If he looks to his router and finds out what device is at the following IP addresses:

He can then turn off those components by ignoring them in discovery:

Or even better he can file an issue on github and get it fixed. Ignoring or hiding errors is not a winner!

Just a quick reply from my spotty mobile connection during commute… The .10 address is a asustor NAS, I think that port might be occupied, I’ll check. The .125 address is a Sony Bravia I think from memory…

The Sony is something I want to have in HA. Not sure about the item on my NAS.

Why would the pywemo think the NAS is something off interest? Like I said, I tried the ignore command… Hmmm…

Thanks folks!

It’s a warning though, not an error. That means it’s already caught, there is nothing to fix. The warning is letting you know it cannot setup the platform and it gives you the information. The whole point of warnings is to be able to ignore them. Otherwise it would be an error. Nothing to fix other than set it up properly (if the component can) or ignore it.

Thanks for pointing that out.

Discovery is looking for potential controllable devices on your network. It will try to discover what devices it does find actually are. To start with things are just IP addresses until they are probed and some information is retrieved or not. In your situation, pywemo is testing an IP address that was discovered to see if that is a Belkin Wemo device.

1 Like

Hi all,

Thanks for the responses thus far. I’d like to point out that yep - I kinda had an idea of what was happening (probing etc) as outlined in my opening post. The point here is that made towards the end of the post - it would good to have discovery limited by a “try” threshold, so it can stop spamming my log and so I as a user can interpret that which is more important. My post title didn’t help, though maybe in a click bait sense :slight_smile:

I tried the discovery ignore belkin-wemo to no effect.

I guess I’m both trying to confirm my understanding and to see if anyone else has any ideas on how to negate the warning messages. It’s not warning me of anything useful!

Thanks peeps,


In the post I mentioned I tried ignore - to no no effect. :frowning:

But you said the sony bravia and asustor nas was the 2 ip addresses. If that is truely the case, you need to ingore those components, not belkin-wemo

Thanks Petro - How do I ignore the asustor NAS though - it’s not in the ignore option list? I’m a wee bit lost…

Hmm not sure on that if it’s not in the list. Now this is a band aide, but you could ignore warnings from the discovery component. I would say It would be best to bring that up with the devs as a future pull request.

As I said in my first post, if you really want the answers try asking your question on the HA Discord channel. The HA developers understand the guts of HA. They will be happy to respond. When you get your answer, post it here.

1 Like