Identifying an entity using "Get Entities" based on an attribute


I’m trying to find an entity_ID that is part of a group, based on a custom attribute. I think I’m close, but I’m still not getting the results.

If I use a fixed value “Z036” as a filter criteria (see screenshot below), I am getting the results I need.

The output is:

zoneID: "Z036"
zoneStatus: "0"
messageType: "ZoneUpdate"
entityID: array[1]
0: object
entity_id: "binary_sensor.tex_zone_z036_w10_2"
state: "off"
attributes: object
device_class: "window"
friendly_name: "Raam bureau zijkant kipstand"
zone_id: "Z036"
window_id: "W10"
window_type: "2"

However, if I replace the “Z036” in the Get Entities node with “payload.zoneID” (as you can see in the previous output, it has value Z036), the node is unable to identify the entity.

I tried “payload.zoneID” and just “zoneID”. What am I overlooking?

It should be “payload.zoneID” if that’s what your input msg property is called, but are you also changing “az” to “msg.” to get it out of the message rather than using a string? Maybe post what your input msg looks like and how you’re trying to configure the “get entities” node.

1 Like

The zoneID/zone_id was just a typo in my post.

However, the “az” should indeed be “msg.”. Thanks, that solved the issue now!
Not sure how I’ve missed that…

Thanks a lot!