IFTTT request DHT11 temperature and humidity with Google Assistant

How can I request the DHT11 sensor temperature or humidity via IFTTT with Google Assistant?

I ask: “tell me the temperature” and he says “the temperature is number°C”
I ask: “tell me the humidity” and he says “the humidity is number%”

do you know how to do it?

You don’t need IFTTT if your DHT11 already has a temperature and humidity sensor in Home Assistant. Just expose the two sensors as climate to the google assistant component and they will report the states. This was released in 0.62

page of istruction?

I have not received the update at 0.62 and does not update me tells me that 0.61.1 is the latest release

If you’re using HASS,io the updates will come a little later.

You can also find information about what to add to your config under the PR on github: https://github.com/home-assistant/home-assistant/pull/11095

thank for the anseware

tried to configure the Google assistant to monitor temperature and humidity, it does not let me take the temperature and humidity.

I did this:

>   entity_config:
>     sensor.dht_sensor_temperature:
>       name: temp
>       aliases:
>         - temp room
>       type: climate
>     sensor.dht_sensor_humidity:
>       name: humidity
>       aliases:
>         - humidity room
>       type: climate

What errors are you getting? Do the sensors get exposed to google assistant? Have you sync google assistant to see the sensors?

The way your configuration has been setup, it will require you to say ‘Hey google, what is the temperature in temp?’ or ‘Hey google, what is the temperature in the temp room?’

If I ask Google Assistant to do a search, I can not find the sensor to configure the temperature to be configured among the configurable devices in Google Assistant

Doesn’t seem like they are getting exposed then. Are you exposing everything by default or do u have it set to false and require expose: true on each entity? Other problem could be that you haven’t synced/unlinked and relinked your google assistant with your [test] to show them.

I’m doing everything from default settings and then my app on google assistant I disconnected and connected 3 times

Do you have configured expose_by_default to be false? You need an to add expose: true to your entity then.

This is my (working) configuration:

  project_id: !secret ga_project_id
  client_id: !secret ga_client_id
  access_token: !secret ga_access_token
  api_key: !secret ga_api_key
  expose_by_default: false
      expose: true
      type: climate
      name: Temperature

Thanks, I almost solved but it tells me that the humidity sensor is not enabled

Does your humidity sensor report % as unit of measurement? If not, configure it that way and try again.

yes, it is reported in%

It’s a DHT11 sensor

Just to make sure we are talking about the same thing:
Do you have configured unit_of_measurement to % for your sensor?


- platform: mqtt
  state_topic: 'whatever/humidity/state'
  name: 'living_room_humidity'
  unit_of_measurement: '%'

yes, it is in percentage as in the picture

What happens if it is in percentage?

As far as I remember the implementation the “%” is used to interpret the sensor as a humidity instead of a temperature sensor. Unfortunately I’m out of humidity sensor right now to test it myself. I’m currently using the temperature functionality only.

thanks for anseware