Ignore-conditions healthy ignored?


since very recently (probably last supervisor update to 2022.10, I cannot do add-on updates (and possibly other ones) anymore.

It merely says “unknown error, see supervisor” while the supervisor logs don’t show any details.

I guess it is related to portainer being outlawed by the recent supervisor update and thus my system becoming (even more) unhealthy.

However, I have had the system ignore health conditions for a long time now (via jobs.json and now again via the ha jobs options --ignore-conditions healthy command. It never gave me trouble but now the addon update is not working anymore and restarting / rebooting did not help.

Is anyone experiencing the same?
Is the “ignore healthy” condition working in combination with portainer running alongside HA?

If it is not in fact about portainer could the recent docker update (20.10.21) mabye be problematic?
I could not find anything related to that except that the minimum is 20.10.17.

Anyway, this is what the ha command says about the system checks.

ha res info
- enabled: true
  slug: dns_server
- enabled: true
  slug: dns_server_ipv6
- enabled: true
  slug: network_interface_ipv4
- enabled: true
  slug: core_security
- enabled: true
  slug: free_space
- enabled: true
  slug: backups
- enabled: true
  slug: supervisor_trust
- enabled: true
  slug: addon_pwned
issues: []
suggestions: []
- docker
- docker_configuration
- job_conditions
- os
- os_agent
- network_manager
- software

Thanks for any clues

Hi Jochen,

I had the same issue yesterday when I wanted to update. For me, I was on docker 20.10.10 so the update of the OS that updated docker to 20.10.21 was the first step. Then the same “unhealthy” complaint stayed on. I checked the supervisor log and it was the fact that I had a portainer container installed on the same docker engine. This is apparently no longer allowed …
I started a discussion/opinion on the facebook group of HA with the plea “Please do not turn into Apple …” and it is animated! The purpose was to ask the developers for some perspective (to the “control” part in their “local control policy”) but I had also some interesting constructive tips (next to the bash for daring to ask this question):

  • rename Portainer to something else
  • go full “core” and not supervised …

Personally, I think that putting Portainer in another stack should work as well but I have not yet investigated how the supervisor checks the existence of non allowed containers.

Go and check out this discussion and I think there are some “Applamists” that replied … :stuck_out_tongue:

Hope this helps.


Well the Point of the ignore conditon is that the supervisor ignores unhealthy system state.

So having portainer and/or other Software should maybe make it unhealthy but thats it. That should be covered by the ignore conditon.

Does your Setup Work with the latest docker Version after removing portainer?


Seems to be resolved after the supervisor Update from 2022.10.0 to 2022.10.2.

Not sure If it is related to some code change or recreation of the supervisor container…