IKEA Fyrtur blinds with SkyConnect

Hi All,

I am new to Home Assistant. I have installed HA on a Raspberry Pi 5 in Docker container a few weeks ago. Most of the stuff was easy to configure.

However I struggle a little bit with my IKEA Fyrtur blinds.
I was able to configure the SkyConnect hub, first I connected an IKEA Askvader switch to it, works flawlessly, but usually it takes minutes to update the state of the switch in HA.

I added the IKEA Fyrtur blinds, also the open/close switch for the blind and the signal repeater.
My network looks like this:

However I am unable to control the blinds, the up button is greyed out all the time, sometimes it responds to the down state, sometimes not, the battery state is always 0%.

My questions:

  • Is it normal for Zigbee to only update state on a Router (mains powered) device that slowly? Takes 2-4 mins.
  • Why the IKEA Fyrtur blind is not controllable?
  • How to pair it with the remote correctly?

Hi Kristof,

Here’s my experience. I have a similar setup as yours with SkyConnect as my Zigbee controller. I have tried several times in trying to reliably pair my Fyrtur blinds to HA with this setup. I did come close once but was missing the battery status. But for all attempts, seems like my setup was not working either immediately or within hours of pairing my blinds and every time I was missing functionality.

I have just recently added the Ikea Dirigera hub to my setup and added the HACS Integration for this hub. The process is to install the phone app, add your blinds to their Smart Home app, (I was able to include the blinds and the remote. No need to add the repeater as the hub is now the repeater). Then install your HACS integration and then add it to HA’s Integration section. Everything will pass thorugh HA and you get full control.

I was hoping not to install an additional hub and control everything through the Zigbee dongle, but at this time, this is not a reliable solution. Hope this helps!

Thank you for your answer.
For me it seems that the initial problems went away. I don’t why, maybe I just had to wait a little longer for the network to normalize or its because I added the original signal repeater to the network (the skyconnect dongle is basically closer than the repeater).

Now only problem I have that I can’t pair the remote. If this can be solved, I will be happy with this setup.