IKEA FYRTUR block-out roller blind support

No, IKEA does not support the code. They have told us they won’t stop us using their internal API (which is that we do), but we’ll have to figure it out ourselves. Fair enough I guess.

You can set the position to a value between 0 and 100. When integrated into HA that means you can create an automation to set it to 60% at 9 am.

I’ve suggested changes to the Home Assistant code base implementing basic support for the cover. Need testers to verify it works before the code can be merged and support added:

Related issue:

1 Like

Well done sir, that’s impressive.
Okay I need to talk the wife into us getting some new blinds.
Whats a good argument given that they come in battleship grey or … battleship grey ?
Still think that if you get this more stable than their integration then they will take a peek at your code before another release. Having said that, how much of the current instability is down to the firmware on the blind itself.??? Only time will tell.
Great work

This is built on top of Ikea’s integration so please don’t expect more functionality than what you have in the app.

(There is no other way of doing it if you use the Ikea gateway.)

@ggravlingen, I don’t have a problem with that.
So given what has been said, Your required infrastructure is ?
I’m guessing here …

  1. An IKEA Tradfri Fyrtur Blind
  2. An Ikea Tradfri Hub
  3. An Instance of HA running on ??? (saw your comment on the other thread, so am assuming this is intended to be temporary until your offering is merged with the official version of HA, and will then be available on ALL installations ???)

So your work is what sits between HA and The Gateway leveraging the API calls you got from their published information ?
Does this require an IKEA Account, i.e. Any need for the Hub (sorry, ‘gateway’) to talk outside the LAN (i.e. not be a ‘gatway’ at all but just sit on the LAN) ?
I’m just trying to get this straight in my head.
Thanks

Anything you do, is a) better than I could have done. b) adds to the body of knowledge on such things and is to be commended. :smile:

Yes, so what happens here is essentially:

  • You pair the Fyrtur with the hub
  • A client connects to the hub and reads the state of the devices, or sends a command to change the state of a device. Eg, raise the blind, dim a light or switch a wall plug off.

This device I mention is normally the app in your phone. Through work in the open source community (not only by myself), we’ve figured out how to create a client that is not the app, but that connects to the hub and reads the state or sends commands.

You can only connect to the hub locally on your own network, so there is normally no way of communicating through the IKEA app if you’re not at home.

What goes on with Home Assistant is that Home Assistant sets up its own client against the hub and speaks to it using IKEA’s commands, converts it into Home Assistant native language and presents it to you, the user, in the Home Assistant app. So you can view Home Assistant as a form of interpreter. Home Assistant, in turn and as you know, can be configured to be accessible form the Internet. Either by using port forwarding on your router or through their own Nabu Casa service.

It might be worth reading this blog post:

1 Like

Thanks for that, an interesting read.
I appreciate that there are others involved in this work, the ‘you’ should be read as the team. I still think it is worthy of praise.
But given all this, where does the instability creep in ? For the standard Ikea setup?
Presumably the weak link in the phone-hub-blind Union is the phone app?
How are you doing with setting schedules and having them carried out from HA ?
What sort of devices does it expose? I assume a cover?

What are your exact instability issues? Do you run a lot of commands against the gateway (eg, flood the device with requests)?

Scheduling the cover in Home Assistant would be done using automations (https://www.home-assistant.io/docs/automation/examples/), where you set the automation to open the blind to 62% at for instance 9 am. You can edit automations in the GUI if you don’t like writing cryptic YAML code.

At the moment, lights and wall plugs are exposed in Home Assistant. When the propoed changes are approved, covers will also be exposed.

Just going by other reports, as I said I’m keen to progress but will need to convince the wife of the need to buy new blinds

Hey ggravlingen, thank you so much for your efforts on this!
I just installed a few of these, if you need any testers I would love to help. However, I am new to Home Assistant and am not a programmer, so if someone can help with an “idiot’s guide” on how to set this up and report/send logs back to study I’m here and willing. If it’s too much hassle to babysit such a beta tester; I completely understand.
Anyways; thanks again for the work, hope this makes it into a hassio update soon!

Any idea when this will be integrated in HA? Thought it would be in .99 but not yet…

1 Like

Maybe in 1.0 :sunglasses:

1 Like

Just had a look at what’s coming to version 0.100 on the RC site for Home Assistant which is set for release tomorrow.

Very excited that one of the new platform additions is basic support for IKEA Fyrtur blinds.

https://rc–home-assistant-docs.netlify.com/blog/2019/10/03/release-100/

Its out now :slight_smile: :cowboy_hat_face:

Yeah this is great!
For some reason it feels like my blind is reversed. 100 is top position (open) and 0 is closed.
The slider does not update when it’s moving but that is maybe how it works. The arrow down is always gray.

How can I get some data that is good to have for analysis?

If you read the other thread : -

You will see that this is the way it HAS to be (0 = closed, 100 = open)
Consider it a valve that let’s in light :joy:

2 Likes

I also got the arrow down greyed out on my blinds. Cant runt blinds down with arror, just up. Moving the slider to value other than 100 works to get the blinds down. Am I missing something?

Seems that if the blinds isn’t in top position and a restart of HA is done, then the up arrow appears and work.
Also the slider doesn’t seems update properly.

I have the opposite - the Up arrow is greyed out for me, but I was able to lower the blinds successfully.

This is probably because you had your blinds were fully open when you restarted HA.
You can do a work-around by open the blinds just a bit and then restart HA. You then will have both arrows working.
I miss typed my post before, I meant the up arrow was greyed out, jut like yours.