IKEA Fyrtur, HO buttons doesn't work properly

Hi all

I have two IKEA Fyrtur blinds. And they worked properly until the last updates of HO and Phoscon/Deconz (I’ve updated both, so I cannot say which updates may have caused this problems).

Now I still can close the blinds with the buttons:

I also can stop them. But I can’t open them. The Up-Button is always grey.
My automation which calls the service “Cover: open” works and opens them both.

Anybody an idea what could cause this problem and how I can solve it?
I know a workaround would be, creating buttons that calls the service. But I’d like to understand this problem :slight_smile:

Thank you very much

I have gone through a lot of pain with these things, I now have a Electrolama Zigbee stick with the new TI chipset and they work fine, as long as the USB repeaters are plugged in.
I don’t know if you use them, but they seem to do more than just extending the range, try plugging them in as intended (in a USB socket near the blinds) and see if that fixes it.
Deconz doesn’t really work well with those, there are hundreds of comments on the github issue for these blinds, I haven’t found any working solution there :frowning:

There are multiple ways to tackle the greyed out button, one that worked for me temporary was to have an automation that triggers on any cover. service call with the matching entity_ids, it would then call a repeat action for ~30sec with a homeassistant.update_entity service call and a small delay.
If you have the IKEA hub, I’d advice you to use it, seems like in the newest HA version the battery states are finally available as well.

1 Like

Thank you very much.
Unfortunatelly it doesn’t work with homeassistant.update_entity. Still the same.
Strange thing is, it worked until I’ve updated Deconz…
And the battery behavior is even more strange… On one blind it shows the battery on the other not. I think they have different firmwares, but before it worked on both.

Before the Update it worked very well for ~3, 4 months. But I had to update it because I bought a new sensor that doesn’t work with the old software version…

As you mentioned… its a pain…

I found a 90% solution now.

I’ve updated the two blind with the following steps:

  1. Download newest firmware
    deconz-rest-plugin/ikea-ota-download.py at f01c40bcb73f17339216bd3c15af4a6bbc3b54e4 · dresden-elektronik/deconz-rest-plugin · GitHub
  2. Update the blinds via GUI
    Technical support

Up/Down buttons work properly now, only the battery state of Blind 1 is still not available.