IKEA lightbulbs not showing up correctly in HA (Zigbee2Mqtt)

Hello dear home assistant gurus…

I have a problem, and with my limited search-engine-skills I have been unable to find even someone with the same problem, let alone a solution. I should also apologise beforehand for any techno-lingo-mistakes I might make, while I try to learn as much as I can, I am not a computer science-major…

I have recently added a Zigbee stick (Sonoff 3.0 -P), and installed zigbee2mqtt. Now everything seems fine so far. The stick is detected, and devices can be added to z2m without any issue. The mqtt-broker can also be accessed, and all start-up-logs seems to indicate everything is well.

Now to the issue at hand:

I have added an IKEA light-bulb (Tradfri, adjustable spectrum). The device pairs fine, and shows up in z2m as fully supported. In the dashboard (of z2m) I can control the light fully and set various behaviours, etc.

However the light does not show up correctly in Homeassistant. The device is there, but it only displays some of the expected entities. Nothing about being a light, and most of the entities can’t even be changed. The light is identified correctly in HA, it shows up with the right name, model number and specs.

              # Device info
              
              TRADFRI LED bulb E26/27 1100/1055/1160 lumen, dimmable, white 
              spectrum, opal white (LED2003G10)
              
              by IKEA
              
              Firmware: 1.0.012

Under the mqtt-info the following is visible

            Entities
            
            * Power-on behavior (`select.lampa_power_on_behavior`)
            MQTT discovery data:
              * Topic:`homeassistant/select/0x6c5cb1fffea3c2f7/power_on_behavior/config`
              * PayloadSubscribed topics:
              * `zigbee2mqtt/bridge/state`
            
            9 most recently received message(s)
            
              * `zigbee2mqtt/Lampa`
            
            10 most recently received message(s)Transmitted messages:
              * `zigbee2mqtt/Lampa/set/power_on_behavior`
            
            1 most recently transmitted message(s)
            * Color options (`sensor.lampa_color_options`)
            MQTT discovery data:
              * Topic: `homeassistant/sensor/0x6c5cb1fffea3c2f7/color_options/config`
              * PayloadSubscribed topics:
              * `zigbee2mqtt/bridge/state`
            
            9 most recently received message(s)
            
              * `zigbee2mqtt/Lampa`
            
            10 most recently received message(s)Transmitted messages:
            
            #### Triggers
            
            * MQTT discovery data:
              * Topic:`homeassistant/device_automation/0x6c5cb1fffea3c2f7/action_on/config`
              * Payload

I seem to be missing almost all of the entities expected?

When deep-diving into the mqtt-tree via mqtt-explorer the light seems to have published four things in the “home assistant”-topic; power_on_behaviour, colour_options, linkquality and update_state, each with a “child” topic of config=

When I use z2m’s dashboard to make a change to the light, a publish is made to the zigbee2mqtt-topic. Note, the device has been renamed to “Lampa”. The publish is simply

        "Lampa = {"brightness":127,"color_mode":"color_temp","color_options":null,"color_temp":354,"linkquality":84,"power_on_behavior":"on","state":"ON","update":{"installed_version":-1,"latest_version":-1,"state":null},"update_available":null} " 

straight into the root of the “zigbee2mqtt”-topic.

Now I also have a couple of Zigbee push buttons, which only publish an action (keypress) and battery state, and these show up as normal in Home Assistant, and can be used to control automations.

Does anyone have any idea of what is going on? I haven’t made any changes to the config of the lights other than the renaming, and removing and re-adding the light yields the same result… I also tried adding another lightbulb of the same make and model, but made no changes to it what-so-ever, and that one behaves just the same, ergo not showing up correctly.