IKEA N2 four button remote, right and left not working

Has anyone had their N2 not respond to right/left button clicks?

When I press up/down it works fine but right left is not responding. When I listen for zha_events nothing happens.
Anyone had this issue and managed to solve it?

I tried to re-pair it but either I failed or it didn’t help.

I just ran into this problem as well. I have several remotes which have worked good for several months. Due to wifi interference I decided to move frequency ~ thus having to re-pairing all devices. Now after reestablishing my network almost all remotes have lost the left & right action.

I use Zigbee2MQTT and mosquitto running in a separate containers

This very problem drove me completely mad for a fair few days. I nearly binned the whole vBox.

I’m using ZHA, the only way i could get it to rejoin the network was to repair the device (4 quick presses of the link button) and when the device is discovering and negotiating, i pressed all four buttons. I have tried this several times with several remotes and it has worked.

now could someone point me at a blueprint that works for these things. everything i have tried doesn’t quite get it all right!

Same problem with the left and right hold button.
The left and right click are still working.
Also the brightness up and down hold are working