IKEA Tradfri bulbs not showing up after configuration

After updating HA to the most recent version, I tried to set up my first Tradfri bulb.
The bulb is properly registered to the hub, and is controllable from within the official Android app.

Although I have tradfri configured in my configuration.yaml, and then restarted HA, the web interface still requires me to set the gateway password and writes it to tradfri.conf.

# configuration.yaml
  host:     !secret TRADFRI_GATEWAY_IP
  api_key:  !secret TRADFRI_API_KEY

Looking at HAs debug logs, it seems that HA recognises the bulb, but it does neither show up in the interface, nor in the “entities” list in the web interface.

// homea-ssistant.log
[pytradfri.coap_cli] Received: {"9001":"lr dinner table", REDACTED

What am I missing?

I went back and deleted the tradri configuration from HA as well as the pre-reqs to install it and followed the steps to a T and don’t have any issues. Maybe try to start setting them up from scratch.

Strangely, after deleting the tradfri section from configuration.yaml it works.
Not sure whey though…