Ikea Tradfri IP change

Hi there, I recently changed the IP Address lease from my Ikea Tradfri Gateway, now I have an integration with the old IP and a new detected one.
Can I change the IP Address within the integration somewhere? I´m worried that all my entites get lost or renamed if I configure the new detected integration.

Same thing here – IP address was changed. The real problem is, that I cannot fix the IP address with my router.

Wish someone would shed some more light on this issue.

Same. I cannot delete the integration and is not letting me add it not even manually

I had this issue and manage to identify the root cause.

When the TRADFRI comes online the first time it gets an IP address from DHCP and it keeps that. Forever.

You can assign a different IP in your router for the TRADFRI’s IP address and then reboot the TRADFRI, but that is when the bug shows up.

Assume it has IP 192.168.5.85. You check the mDNS announcements. It shows up with that particular address.

Now you link the TRADFRI to your Home-Assistant.

Then you go into your router and set a static IP, say 192.168.5.20. You reboot your TRADFRI, and you take the IKEA app. It all still works. Great!

BUT, now you see a second TRADFRI popping up, as shown on the screenshots above.

The issue is that when you go and check the mDNS announcements you’ll see that the IP is not set to 192.168.5.20. It’s set to some random 169 address.

I am going to set a static IP and reset the TRADFRI, and see if then the mDNS is set correctly.

@AdmiralRaccoon Did you find out how to best do this? I am in the same situation, apparently I configured the integration in the UI with the IP address and now, several months later, when I have rebuilt my network I want to change it to use the hostname instead.

Do the integration need to support this in some way? I have seen that the MQTT integration supports changing the server hostname.

If I remove the integration and add it again, will I need to reconfigure all my entities?

To be honest, i don´t remember exactly what I did that day, but I would remember if all entities were lost.
Maybe I did make a snapshot and deleted both integrations, rebootet, configured tradfri with the new ip and all entites were restored.

I had this problem today. Not even sure what I did, removed the instance with old IP and restarted. When I came back, it was there with updated IP address. Only thing I had to redo was setting the areas of the lights.

Had the same problem yesterday. Changed IP of Tradfri gateway and homeassistant showed the old integration as disconnected and offered a new one with the new IP.

To solve this I opened a bash in my homeassistant docker container with “docker exec -it homeassistant /bin/bash” and modified the integration config with “vi /config/.storage/core.config_entries”. I just changed the Tradfri IP in there, saved and rebooted. Everything worked like a charm

Note: This wont work if you replaced the gateway. Though you might be able to edit the keys there as well, but I did not test this.
On a closed HA system (I use HA blue) you might also need “Advanced SSH and Web Terminal” addon disabling “protection mode”. See GitHub - hassio-addons/addon-ssh: Advanced SSH & Web Terminal - Home Assistant Community Add-ons