IKEA Tradfri on FreeNAS 11


I’m a new user to HA and I’m running FreeNAS 11.0 where I recently installed HA on to a new jail using this guide:

I’m trying to setup the IKEA Tradfri component using the instructions on the component page:

Everything goes well until I enter the following command:

./configure --disable-documentation --disable-shared --without-debug CFLAGS=“-D COAP_DEBUG_FD=stderr”

In Putty I get a couple of warnings

checking for ctags... /usr/bin/ctags
configure: ==> Note: your ctags does not support '--c-kinds'!
configure: ==> Most likely, you are using the GNU Emacs ctag and not exuberant c tag
configure: WARNING: ==> This option is required for target 'update-map-file'
configure: WARNING: ==> which is not a problem if you just want to build the library libcoap.


checking operating system... configure: WARNING: ==> Currently unsupported operating system amd64-unknown-freebsd11.0!
configure: error: ==> If you can provide patches to support your operating system please write to '[email protected]'.

If I then run


I get the following

make: no target to make.
make: stopped in /libcoap

I checked the /libcoap directory in the jail and I have Makefile.am, Makefile.in and Makefile.libcoap but no Makefile (no extension) which, I believe, is what I need in order to successfully run the make command.

I can also see the IKEA Tradfri configure button on the HA Home page but when it I enter the passkey at the prompt, the prompt remains without any errors and nothing happens. I’m assuming I need to complete the make commands above.

Can anyone help with how to get around this?


I have the same problem! Some help would be appreciated :slight_smile:

Right so I guess the problem is that libcoap isn’t freebsd compatible :frowning: so I found this pull request:

I’ve followed the steps in the TradFri tutorial of home assistant and merged the pull request on my own project.Using make it generates the following errors:
“/libcoap/ext/tinydtls/Makefile” line 61: Missing dependency operator
“/libcoap/ext/tinydtls/Makefile” line 89: Need an operator

using gmake i’m able to do the make file successfully but it generates a lot of warnings

After that I did the make install which also generated errors the same errors as above. gmake install worked with a lot of warnings. Though I don’t see the component pop up in HomeAssistent though so I guess it’s still not working properly :frowning:

Ah I forgot to edit the configure.yaml file as stated in the tradfri tutorial. I’ve added the tradfri device with the IP address and api_key and now it’s working via Home Assistant! :smiley:

I’ve got to successfuly compile and install libcoap using your fork of libcoap, but now I don’t seem to be able to connect via the dialog or config file.