IKEA TRADFRI Remote (5 button version) through ZHA events

Personally I don’t see the added value with Blueprints. I haven’t looked into it because Frenck already created on that looked similar to mine.

I care to disargee. I used that blueprint since it came out and even though it’s well established, it doesn’t do the color switching which drove me mad. I definitely think this could be a valuable blueprint going forward.

That’s a nice compliment, thank you! I’ll have a look at converting it to a blueprint

3 Likes

Awesome. I suggest you put it in a new post in the Blueprint exchange as well. I guarantee you’ll get a thousand hits in a day :wink: Thanks, man!



:wink:

1 Like

Has anybody got any idea why I am not seeing any events fired when I listen to zha_event? :thinking:

We’re not able to help you if you hold off all the usefull information. You’re not giving us much to work with…

Sorry.
HA Core Version: 2021.8.8
ZHA Integration using Sonoff Zigbee dongle CC2531.
I have the 5 button TRADFRI Remote connected and shown with only a battery entity.
When I listen to zha_event in developer tools while pressing buttons I am not getting any events fired!

Any help is greatly appreciated! Thank you.

Perhaps you can try re-connecting the device. Here is a screenshot of one of mine, for comparison.

When listening, this is what I got after I pressed the center button.

Thanks. I’ll try doing that. Mine looks almost exact:

LQI is very low. Is it far from the closest controller / router? RSSI is unknown.

I don’t have a clue why! It is about a feet away from the router which it is connected to according the network below:

I take it that reconnecting it didn’t work?

So, I haven’t tried that yet. BUT, it worked ONCE. Then nothing. I am getting 74% battery now but when I first synced it there was only 37%. So I am going to replace the battery and see. I don’t know why it is working randomly. Maybe the remote sat on a shelf for a long time and the battery has drained. I will update you as soon as I do that. Thanks a lot.

Best of luck

Thanks. That didn’t work. :disappointed: I really don’t know why it did work once but not again. Probably the Zigbee Dongle can’t handle the number of devices but I have two TRADFRI repeaters as well. Really don’t know what’s wrong now. Probably upgrading to Conbee or another type of a well-known Zigbee stick might be the solution.

How many devices do you have connected? I have about 41 devices connected to a Conbee II but used to have them on a Sonoff CC2531. Both are able to handle them all.

OMG. I only have 8 leak detectors and two repeaters. So most probably that’s not the case. I am really lost now :disappointed: :disappointed: Don’t know where to start getting hold of this!!!

Try the zigbee2mqtt addon to confirm the remote works as expected. To do this, you need to remove the zha first.

1 Like