Ikea Tradfri Remotes Strange behaviour in Automations, Zigbee2mqtt error

Dear Forum,

I am having some trouble with an automation, which I cannot wrap my head around :wink:

What works:

  • I have two Ikea tradfri remotes, that are fully working (If I look in “devices” I can see the remotes, if I press the buttons, HA shows me that the button was pressed)

  • I have an automation, that, whenever the toggle button on one of the remotes is pressed, the light in a room is toggled.This works for remote No 1 flawlessly. If I do not use the toggle button on remote No2 but another button, I can also toggle the light in this automation.

What does not work:

  • The toggle button of remote No. 2, although HA registers the click and all, does not trigger the automation

I am highly confused, any ideas?


Really? You want us to guess what your failing automation looks like?

Well, the automation works flawless with remote 1. The trigger part of remote 1 shows a “triggered” info when I press the button and everything is well. the trigger part of remote 2 is exactly configured as for remote 1, but does not show the “triggered” info if the button is pressed.
If I look at the “devices” both remotes behave the same, when I press the button on remote 1 or 2, HA registers the button click.

Here is the automation yaml code:

alias: OG_MA_Licht per Fernbedienung
description: ''
  - platform: device
    domain: mqtt
    device_id: 443955ada8784f0a87447fb4fd53c314
    type: action
    subtype: toggle
    discovery_id: 0x90fd9ffffe88acc1 action_toggle
  - platform: state
      - switch.og_ma_sekschalter
  - platform: device
    domain: mqtt
    device_id: 18893aebb7114da4a73b32826217721f
    type: action
    subtype: toggle
    discovery_id: 0x90fd9ffffe526f7b action_toggle
condition: []
  - service: light.toggle
    data: {}
        - light.og_ma_tuerseite
        - light.og_ma_leselampe
        - light.og_ma_fensterseite
mode: single

Did you create the automation using the GUI?

Yes, just found that sharing the yaml is easier than screenshotting the automation.

So I solved the problem. It was not the automation, but the Zigbee2mqtt addon. I renamed the remote2 in there and suddenly everything worked as expected.