IKEA Tretakt smart plug wrongly recognized

IKEA Tretakt smart plug is identified as having dimming capabilities, which is not true. This device has no such capabilities. It needs to be corrected. Thank you.

Is this a Zigbee device please?

Are you using ZHA or Z2MQTT?

New devices that don’t follow a spec fully (IKEA are world renown for this), need a custom “Quirk” file created and added to the Zigbee coordinator:

Seems he is using ZHA. It’s supported correctly in Z2M. IKEA E2204 control via MQTT | Zigbee2MQTT

It’s a Zigbee device. See the attached screenshot [with red Z icon in ZHA]. Tretakt plug is a new device in offer, so there are no quirks available yet. I described the issue so that the developers could address it. I do not expect an immediate solution. Meddling with the “On level” parameter has no effect on anything. The slider is just there. Doesn’t hurt :slight_smile:
Nevertheless, thanks for the hints.

You need to submit a device support request for a custom ZHA Device Handler (also known as a quirk) as an issue to a GitHub repository to have the zigpy/ZHA community there look at it, read and follow → https://www.home-assistant.io/integrations/zha#how-to-add-support-for-new-and-unsupported-devices

If you do not want to develop such a “quirk” Python script yourself, you can submit a “device support request” as a new issue to the ZHA Device Handlers project repository on GitHub:

1. Sign in to GitHub.
2. Select New issue and follow the instructions.

** New device support requests require the device signature + diagnostic information.*
** You may also need to actively help in further testing or provide additional information to the volunteering developers.*

Note that submitting a new “device support request” does not guarantee that someone else will develop a custom “quirk” for ZHA. The project relies on volunteering developers. However, without “device support requests”, the developers may not be aware that your specific Zigbee device is not working correctly in ZHA.

PS: FYI, also check out this for a little more info on ZHA Device Handlers (ZHA-Quirks):

1 Like

@3jam3 can you try with this quirk?

1 Like

thank you !

Your quirk did the job. Thanks a lot.
Now it’s time to add this to the official repository.

I have tried this quirk but my device still don’t find any Tretakt, at all :confused: I have Raspberry Pi, with ZHA and Raspbee 2. Have any idea what I can do?

Bring your Tretakt close your Raspbee when pairing.

How close are we talking? Mine right now is maybe 2-3m away, have no issue when I try to add Sonoff Temp sensor.

Last time I added a IKEA plug, I used 15cm. Once they are paired, it does not matter how far they are.

Still nothing shows up :frowning:

You need to be more patient. This plug sometimes requires several attempts. This was the case for me, as it connected on the third or fourth attempt. Another unit did it faster, on the first try.
BTW, I assume you did a reset.
Is the device in the picture and next to the plug a router with WiFI?

The one to the left is Fiber to the home/apartment, but underneath the plug is the wifi router. I know that wifi may disturb the Zigbee signal, but all other switches and sensors work without issue, just the Ikea Tretrakt that is not discovered after several attempts :frowning:

Try from different location. Or maybe your TRETAKT is defective.

Right now they are added via Philips Hue, but I do want to add them in ZHA instead, I have tried several different location, I have added two Tretakt to hue without issues, but dose not show up in ZHA, I have added a quirk (don’t know if I added it correctly or if the tretakt.py is correct configured byt still nothing shows up in ZHA.

I think my HA needs an update, or Rasbee2 to work with Tretakt. But I highly doubt that Tretakt is faulty :frowning:

Did you remove it from Hue beforehand? I assume you also did a reset.

I tried several times with ZHA, from different location, tried another Tretakt to ensure it is see if ZHA could not see the second one. After that I assumed tretakt could be faulty so I tried Hue instead and they find it instantly.

Reset te plug, yes, reset the ZHA, no. Is that something I need to do time to time? If you mean ZHA, why do I need to reset it if other lights and sensors works?

Sorry for all the dumb questions but due to being new to Zigbee, I’m trying to learn as much as possible, and that l you for all tips and help so far!

You are just out of luck, it seems. Or your Zigbee controller doesn’t like IKEA :man_bowing: