I'm confused about TTS settings in configuration.yaml vs Voice Assistant

My configuration.yaml file has only 2 lines about TTS, which I don’t think I added/changed myself:

  - platform: google_translate

But in my Wyoming Voice Assistant settings I set it to use Piper, and the voice assistant pipeline is using Piper.
So I don’t know why configuration.yaml has those lines, and where I may add further TTS settings.
I’m digging into this for another reason: I want my TTS to be totally local, which it almost is, but the ESP32 Voice Assistant device is being pointed to the full external address of Home Assistant which is slow and defeats the purpose of having a local voice assistant.
So I’m hoping to find a way to use a local IP/hostname that my device can play the audio from.
I’m not sure I’ll find it in TTS settings, but maybe a workaround might be if I set the cache folder to another host on the LAN that somehow I can point the player to.
I would prefer a simpler solution, but haven’t found one yet and sorting the TTS settings confusion would be helpful anyway.
Thanks to all helpers.

That setting is a default configuration option that you can comment out if you want to be sure that it’s not used. Also, depending on what hardware you’re using to run Piper, it’s going to be somewhat slower than online TTS.

Thank you @daywalker03. So, where are the TTS settings for the Voice Assistant, that I can try to fix my problem with?
RE piper I can see in the logs that AFTER the link is received by the ESP32 is when most delay happens. I run Wyoming on a GPU so it’s quite fast, both sides (STT/TTS).

Settings → Voice Assistants and click on the Assistant you’re using. In the popup, the fourth box will show what the Text to Speech engine is.

I know how to find what it is, etc, I did set it up; I’m trying to find ways to specify cache, etc.

I don’t think you can, at least not easily.

So, is that default configuration used anywhere? I want to mark this as solved; it just feels… iffy to have something in configuration.yaml that’s not used anywhere…
Actually I can’t even find how/where to mark it as solved…

It can be safely disabled since you have Piper installed. The only place I’ve ever seen it used is in the Media Sources sidebar entry.