I'm having a heck of time with the app & Wear OS login

I had it working and the battery sensor updated for a while but then stopped.

I then uninstalled the app on the watch and re-installed it but now cannot log in…

I login successfully using the phone but it just returns here…

I also am unable to login directly via the instance URL even though the watch is connected to my 2.4GHz Wi-Fi.

**Updated ** - see next post!

Just had another go at it but used a different approach as per a keyboard I just installed which instructed me to install the app in Wear OS PlayStore via Apps on my Phone. So I chose that this time around and it was a completely different experience compared to installing it via My Apps.

I selected to login via Instance, entered my login name, password and 2FA token and it’s now working. I could not get past choosing Instance before as it would say Connecting… and time out. I now for the first time see Areas!

screen

image

That was NOT why it worked! It was because I had the watch connected to charger which triggers Wi-Fi (and Bluetooth) always on. Without being on charge, apps are supposed to trigger a Wi-Fi connection when they need it but for some reason, the HA mobile app is not and I get a spinning circle trying to connect to my instance. After about two days, the app on my watch was haywire again. I’ve re & re’d both watch and phone apps yet again after first purging storage on phone and removing the integrations in Home Assistant. I had to connect the watch charger to get the experience I had before.
Something is not right with the app & wi-fi connections on the watch. While HA is spinning if I go to watch connections, wi-fi, it shows last used SSID which THEN changes to connected. But it does not stay that way when I return to the HA app on the watch and try to login again. And, login via phone app does not work for me…

Data on the app actually routes to the phone via the BT connection when wifi is not connected thats part of Wear OS, the app doesn’t need to create a wifi connection when its not available.

Seems like you are hitting an issue that does not impact all users. May want to give this thread a read through to see if you need to adjust your own network setup to account for the proxy that wear OS does when there is no wifi connection.

My watch is Wear OS 2.0. After digesting that thread it seems relevant.
I’m using split DNS but even if I configure the phone app to connect while on my local Wi-Fi SSIDs to http://192.168.1.104:8123, the watch app cannot connect unless I turn off either phone Wi-Fi or Bluetooth thus forcing the watch to use its local WiFi connection which then works. So it only uses the public URL while connected to phone over Bluetooth and despite my local split DNS server setup, it would seem to resolving the internet URL via Google DNS to my public IP which of course fails as I have an ISP provided modem with no option for NAT reflection. The thread does not give a solution for this scenario…

The solution appears to be that this only works either when using Nabu Casa or you are able to configure loopback/harpin NAT on your firewall.

I changed my ISP provided Actiontec T3100 router to passthrough mode, setup a Sophos XG105 firewall and configured my inbound port 443 with a Reflexive Rule which does loopback processing on LAN subnet to WAN IP address connections and the HA app on TicWatch Pro3 running Wear OS 2.0 is now working.

1 Like