I'm looking for a programmer


#1

Hi hello! I am looking for someone with programming experience that can help me to get my Homewizard intergrated in home assistant.
There is allready some line of code to get homewizard into homebridge. I think that i would be a peace of cake for somebody with some programming experience.
I only want to use home assistant for all the devices in the house.
Homewizard is a product that can control a lot of different things. The most important one is my somfy sunscreen. Als home assistant has the information about my total engery used in house.

Where can i find someone that can help me with this? I am willing to pay for it.


#2

Hi,

I think that it would certainly be a cleaner install if you control everything directly from home-assistant. Does the Homewizard box also handle direct communication with hardware or does it just integrate wifi?

Did you already check this:


And that here:

You can see here that he use the script to control homewizard from home-assistant.


#3

Which motion sensor are you using? (brand/model/link-> z-wave, wifi?) Same for the smartware switch (brand/model?)
Does the somfy sunscreen work via wifi?


#4

The Homewizard box handles direct hardware communication.
The somfy uses RTS technolagy. Homewizard is the only (hub) that can control this so far.

A little list of devices
2 x Smartwares SmartHome Funk-Steckdose 3600W SH5-RPS-36A
4 x Smartwares Magnetschalter SH5-TSM-A
COCO ACDB-6600AC Türklingel Set
Rauchmelder für HomeWizard
Smartwares Bewegungsmelder SH5-TSO-A
Somfy RTS Sunscreen

i also have the Energy link kit only i coulnt find a englisch or deutsche site. This thing gives me realtime tracking of the total engery useged in the house. It would be real nice if this can be shown on the hass interface aswell

this is the first time i see the bass script en web script. i have no idea how to start.


#5

@Dsm010 Did you ever find a solution for this question?


#6
    Hello,

    This is my solution:
    In your browser type:
    http://IP_OF_HOMEWIZZARD:PORT/PASWRD/get-status
    Now you can see all of your switches and their ID number.

    In the command_on and _off line behind /sw/ you see 0 were 0 is the ID number of the switch you want      to control.
    In the value_template behind switches you see[0] were 0 is the ID number of the switch you want to monitor.

    For instance, i made a vswitch0: and as you can see this 0 is filled in at all the locations i mentioned above.
    For vswitch1: it is 1. etc, etc.

        switch:
          - platform: command_line
            switches:
              vswitch0:
                command_on: curl “http://IP_OF_HOMEWIZARD:PORT/PASSWRD/sw/0/on”
                command_off: curl “http://IP_OF_HOMEWIZARD:PORT/PASSWRD/sw/0/off”
                command_state: curl “http://IP_OF_HOMEWIZARD:PORT/PASSWRD/get-status”
                value_template: ‘{{ value_json.response.switches[0].status==“on” }}’
                friendly_name: THE_NAME_YOU_GIVE_IT
              vswitch1:
                command_on: curl “http://IP_OF_HOMEWIZARD:PORT/PASSWRD/sw/1/on”
                command_off: curl “http://IP_OF_HOMEWIZARD:PORT/PASSWRD/sw/1/off”
                command_state: curl “http://IP_OF_HOMEWIZARD:PORT/PASSWRD/get-status”
                value_template: ‘{{ value_json.response.switches[1].status==“on” }}’
                friendly_name: THE_NAME_YOU_GIVE_IT

    etc, etc.........

    Good luck!

#7

Hi, I am also new to home assistant, just because development from my homewizard is stopped. I would like to migrate slowly to newer stuff, but for now would also like to have the opportunity to connect my homewizard.
I am struggling with the switches and the command_line options, not getting it through the config checks:

the part of the configuration.yaml for the homewizard connections:

switch:
  - platform: command_line
    switches:
       vswitch0:
          command_on: curl “http://192.168.2.4/xxxxxx/sw/0/on”
          command_off: curl “http://192.168.2.4/xxxxxx/sw/0/off”
          command_state: curl “http://192.168.2.4/xxxxxx/get-status”
          value_template: ‘{{ value_json.response.switches[0].status==“on” }}’
          friendly_name: Lampje Hal
       vswitch3:
          command_on: curl “http://192.168.2.4/xxxxxx/sw/3/on”
          command_off: curl “http://192.168.2.4/xxxxxx/sw/3/off”
          command_state: curl “http://192.168.2.4/xxxxxx/get-status”
          value_template: ‘{{ value_json.response.switches[3].status==“on” }}’
          friendly_name: Buitenlamp voordeur

this keeps giving lost of errors, tried some changing is spaces etc, but nothing sofar.

Configuration invalidCHECK CONFIG

Invalid config for [switch.command_line]: invalid template (TemplateSyntaxError: unexpected char ‘“’ at 44) for dictionary value @ data[‘switches’][‘vswitch0’][‘value_template’]. Got ‘‘{{ value_json.response.switches[0].status==“on” }}’’ invalid template (TemplateSyntaxError: unexpected char ‘“’ at 44) for dictionary value @ data[‘switches’][‘vswitch3’][‘value_template’]. Got ‘‘{{ value_json.response.switches[3].status==“on” }}’’. (See ?, line ?). Please check the docs at https://home-assistant.io/components/switch.command_line/


#8

Is that a copy and paste of your actual config or did you type it out?

As it looks like you are you using

“    ‘

instead of

"      '

? (notice yours are curly and mine aren’t)


#9

Ooo, I feel so stupid now, that took me some hours yesterday…:tired_face:
Of course, when I read your post, I thought YES, ofcourse thats it.
I copied it from someone else and never noticed it.

Just changed it, and off course it works fine now…

THANKS!!!